AMP ADS Instances always getting created as 'Standalone' and not connecting to oneanother

  • 84 Views
  • Last Post 18 April 2019
  • Topic Is Solved
Eizock posted this 18 April 2019

Problem: If i create ADS Instances from the Commandline and put them into 'Controller' or 'Target' via the Webinterface Firstrun-Wizard, they always end up being 'Standalone'. (And thus not connecting to oneanother)

OS Name/Version: Debian GNU/Linux 9 (stretch)

Product Name/Version: AMP Release "Hawking Starman" v1.7.4.1, built 11/04/2019 13:12

Steps to reproduce:

  • Create 2 LXC Containers
  • Install AMPInstancemanager into both of them (without suggests)
  • Create a "ADS-Master" as a Controller in first LXC Container (IP: 10.20.10.30/16)

    ampinstmgr CreateInstance ADS ADS-Master 0.0.0.0 8080 *Licence* admin *Password*
    
  • Set it up via the firstrun-wizard in the Webinterface
  • Create a "ADS-Minecraft" as a Target in second LXC Container (IP: 10.20.20.1/16)

    ampinstmgr CreateInstance ADS ADS-Minecraft 0.0.0.0 8080 *Licence* admin *Password*
    
  • Try to connect it to the "ADS-Master" via the firstrun-wizard in the Webinterface

    Friendly Name:      ADS-Minecraft
    ADS Controller URL: http://10.20.10.30:8080/
    Username:           admin
    Password:           *Password*
    
  • They end up being two different, unconnected controllers

Expected behaviour:

  • 'ADS-Minecraft' appears in Webinterface of 'ADS-Master'
  • 'ADS-Master' can create & manage Instances on 'ADS-Minecraft'

Console of ADS-Master

    [07:28:21] [Auth:Anonymous Activity] : Authentication attempt for user admin from 10.20.20.1
    [07:28:21] [Auth:admin Activity]  : Authentication success
    [07:28:44] [Auth:Anonymous Activity] : Authentication attempt for user admin from 10.20.20.1
    [07:28:44] [Auth:admin Activity]  : Authentication success
    [07:36:11] [Auth:Anonymous Activity] : Authentication attempt for user admin from 10.20.20.1
    [07:36:11] [Auth:Anonymous Activity] : Authentication failure for user admin from 10.20.20.1 - Bad Password.
    [07:36:18] [Auth:Anonymous Activity] : Authentication attempt for user admin from 10.20.20.1
    [07:36:19] [Auth:admin Activity]  : Authentication success

There does not seem to be anything related in the Console of the "ADS-Minecraft" instance.

Actions taken to resolve so far:

  • Checked Firewalls: All Disabled
  • Updated the System to the latest Version
  • Confirmed that the two Containers can communicate ('wget' the AMP-Webinterface of eachother)

Any Help is appreciated.

Order By: Standard | Newest | Votes
Mike posted this 18 April 2019

Use ampinstmgr quick instead when setting up ADS for the first time in each container instead of CreateInstance

Eizock posted this 18 April 2019

Behaves exactly the same. :c

Mike posted this 18 April 2019

On the one you're trying to setup as a controller, does it have an Auth server set in AMPConfig.conf? Also what does ADSModule.kvp show as the setup mode?

Eizock posted this 18 April 2019

Here is the ADSModule.kvp:

*Snip*
Limits.ServiceStore=C:\AMPDATA\
*Snip*
ADS.Mode=Controller
*Snip*

It seems off thath he shows a Windows path in there?

Here is the AMPConfig.conf:

*Snip*
################################
# Login
################################
Login.UseAuthServer=False
# Login.AuthServerURL - The URL for the ADS instance providing authentication when using UseAuthServer
Login.AuthServerURL=
Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=
*Snip*

There does not seem to be any AuthServer.

Mike posted this 18 April 2019

That setting only applies to Windows systems, it just gets ignored otherwise and nothing changes it.

Can you delete ADSModule.kvp and re-run the setup for the target please?

Eizock posted this 18 April 2019

Those are both from the Controller!

Should have specified, sorry.

Did it nevertheless.

It threw a Unable to register as target, 'A remote instance with the specified Instance ID already exists' error.

Mike posted this 18 April 2019

Ah it was the target configuration I wanted to look at. Okay go to the controller and delete the target, then re-register the target.

Eizock posted this 18 April 2019

How should I delete the target from the controller if its not showing up in the Webinterface?

Mike posted this 18 April 2019

If it's not showing up at all while the target is complaining that its already registered then something else has gone wrong. As a sanity check restart the controller and empty your browser cache.

Eizock posted this 18 April 2019

Ok. So restarting the Controller fixed it for some reason. Thank you very much.

Close