AMP installer on Ubuntu 20.04?

  • 283 Views
  • Last Post 18 June 2020
  • Topic Is Solved
frybread posted this 25 April 2020

I know it's brand-spankin new, but has anyone had a successful AMP install yet on the new Ubuntu 20 LTS?

No luck for me so far, here's what I get:

Installing nginx and certbot...
/dev/fd/63: line 420: [: missing `]'

and

Note, selecting 'python-is-python2' instead of 'python'
Note, selecting 'python-dev-is-python2' instead of 'python-dev'
Package python-virtualenv is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-virtualenv' has no installation candidate
[Error] Certbot failed with code 100
Failed to configure nginx. Please check /root/getamp.log . Aborting...

I don't see anything strange in getamp.log:

Sat 25 Apr 2020 06:24:57 AM UTC
Get:1 http://us.archive.ubuntu.com/ubuntu focal InRelease [265 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [89.1 kB]
Hit:3 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu focal-security InRelease
Hit:5 https://repo.cubecoders.com debian/ InRelease
Fetched 354 kB in 1s (369 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Calculating upgrade...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
dirmngr is already the newest version (2.2.19-3ubuntu2).
software-properties-common is already the newest version (0.98.9).
apt-transport-https is already the newest version (2.0.2).
dnsutils is already the newest version (1:9.16.1-0ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--2020-04-25 06:25:40--  https://dl.eff.org/certbot-auto
Resolving dl.eff.org (dl.eff.org)... 151.101.0.201, 151.101.64.201, 151.101.128.201, ...
Connecting to dl.eff.org (dl.eff.org)|151.101.0.201|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 80073 (78K) [application/octet-stream]
Saving to: ‘/usr/local/bin/certbot-auto.1’

     0K .......... .......... .......... .......... .......... 63% 2.72M 0s
    50K .......... .......... ........                        100% 26.8M=0.02s

2020-04-25 06:25:41 (4.03 MB/s) - ‘/usr/local/bin/certbot-auto.1’ saved [80073/80073]

Reading package lists...
Building dependency tree...
Reading state information...
nginx is already the newest version (1.17.10-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Synchronizing state of nginx.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable nginx

Order By: Standard | Newest | Votes
Mike posted this 25 April 2020

Certbot doesn't work on Ubuntu 20.04, it's an issue with Ubuntu's packaging and isn't an AMP issue.

julian posted this 18 June 2020

Found a workaround: manually installing certbot and the nginx packages manually- ref https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-20-04

  • Liked by
  • SamEureka
Close