Ark Server not shutting down and dosn't save.

  • 241 Views
  • Last Post 3 weeks ago
  • Topic Is Solved
PointOfHorizon posted this 24 May 2019

So I have spent the most of the day setting up the ARK server on AMP but I have run into some issues to do with the server stopping and restarting.

If I tell the server to stop within the status tab in the server webpage it will never actually shut down and just sit there using my ram until I hit the kill button (but doing that will prevent the server from saving before it shut down) And if I hit restart the server will shutdown instantly (does not save) and doesn't even restart again.

Would anyone know what is going on?

Order By: Standard | Newest | Votes
Mike posted this 24 May 2019

There's a bug in the ARK server itself that makes it not respond to a shutdown request via RCON. We're looking at alternatives but the ARK server is pretty badly built.

PointOfHorizon posted this 26 May 2019

There's a bug in the ARK server itself that makes it not respond to a shutdown request via RCON. We're looking at alternatives but the ARK server is pretty badly built.

Thanks for the quick response. Ill just have the server save contently as a work around until its all sorted.

AbhorrentJoel posted this 3 weeks ago

I know this is 5 months old and marked as solved, but I am a bit anxious about creating even more threads for issues - especially since this one has been acknowledged. I understand that ARK may have been the cause of the issue at the time, but perhaps this could be addressed in a response to whether this is still the case.

I am currently on FastTrack (v1.9.0.0, built 30/10/2019 03:00) on Ubuntu 18.04.3 LTS and can confirm that the server will not gracefully close. In fact, the console nor the server seem to respond to any commands.

I have used LGSM previously for server management, but I am not sure what method they are using and whether or not it is graceful.

Mike posted this 3 weeks ago

This is something that has been validated recently. Check AMPs log for any issues with the RCON connection.

AbhorrentJoel posted this 3 weeks ago

Just to note, this is version 300.3 of ARK.

The log indicates that the RCON connection was successful:

[19:28:55] [ARK:[removed] Info] : Startup completed in 00:01:19.0715890
[19:28:55] [ARK:[removed] Info] : RCON connection successful.
Keep Alive

Netstat also shows that ARK RCON is listening (here on port 34197) and there is an established connection between AMP and ARK:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:34197           0.0.0.0:*               LISTEN      [removed]/ShooterGameSe
tcp        0      0 127.0.0.1:35226         127.0.0.1:34197         ESTABLISHED [removed]/AMP_Linux_x86
tcp        0      0 127.0.0.1:34197         127.0.0.1:35226         ESTABLISHED [removed]/ShooterGameSe

Stopping the server does not work in the console, nor does it in the panel. AMP does write the commands in the console, as visible in the ARK instance console:

RCON
18:32:55
 saveworld
 doexit

AMP also logs that it has attempted:

[19:32:55] [API:[removed] Activity] : Stopping the application.
Keep Alive

Close