Can't log into AMP after update

  • 341 Views
  • Last Post 02 December 2021
  • Topic Is Solved
fbiancol posted this 02 December 2021

OS Name/Version: Windows 10 Enterprise v20H2

Product Name/Version: AMP 2.3.0.4

Problem Description: used command line to update, and now cannot log into AMP web console. Error message says "Unknown Reason"

Steps to reproduce:

Step 1 Opened command prompt as Administrator

Step 2 navigated to AMP folder

Step 3 Ran this command: ampinstmgr.exe --UpgradeAll Seemed to run succesfully

Actions taken to resolve so far: read the forum, and tried to upgrades multiple times using the command above. Also tried ampinstmgr.exe --NoCache UpgradeAll Rebooted.

Still cannot login. Have tried accessing the web console from 2 different computers, same outcome...cannot login...Unknown reason.

Order By: Standard | Newest | Votes
Mike posted this 02 December 2021

  • Stop all AMP instances
  • Run AMPs installer in repair mode
  • Run 'ampinstmgr --nocache upgradeall'
  • Reboot (Do not skip this!)

fbiancol posted this 02 December 2021

Thanks Mike.

A couple of followups:

  • To stop the AMP instances.... I assume I use: ampInstmgr --StopAllInstances ?

  • What is "repair mode"? I looked through the ampinstmgr switches, and the only one that has the word repair in it is "repairauth" ....is this the one? If so, it requires a "mode" and URL to be supplied.....what mode do I supply for the command?

thx Fabio

Mike posted this 02 December 2021

The repair mode is the original installer, ampsetup.msi.

fbiancol posted this 02 December 2021

Thanks again Mike. Your instructions resolved the issue.

Note: I was unable to find "repair" mode for the installer....so I just ran the "typical" installation, and it seemed to work.

Thank you Fabio

OnklSwörny posted this 02 December 2021

Same Problem here, can't resolved by the steps below.

fbiancol posted this 02 December 2021

FYI....it appears there is a new build....2.3.0.6....when I did the update, it moved to the new build. Not sure if that was the fix, but that's what happened.

fb

OnklSwörny posted this 02 December 2021

Right i use 2.3.0.6, but now it works. I'm running in trouble every time i update my installation. :(

What are the right steps to update an Windows AMP Installation?

For now it works again.....

fbiancol posted this 02 December 2021

One of the admins are best to answer your question officially, but here is what I do (in Windows 10):

Log in with the correct user ID that the AMP installation was installed under (this is really important...learned that the hard way). Run command prompt as Administrator. Navigate to the AMP folder.

then:

  1. Stop all instances: ampInstmgr.exe --StopAllInstances

  2. upgrade using the following command: ampinstmgr.exe --NoCache UpgradeAll

  3. REBOOT

That usually works for me.

  • Liked by
  • OnklSwörny
OnklSwörny posted this 02 December 2021

Ok,

but first you install the MSI (ampsetup.msi) with the "AMP-User" (non-admin) right?

Mike posted this 02 December 2021

With whatever user you originally used to install AMP but yes.

  • Liked by
  • OnklSwörny
Close