Cannot connect to newly created AMP Instance on brand new install of AMP

  • 137 Views
  • Last Post 16 February 2021
Coldreactor posted this 15 February 2021

Hey,

I just installed AMP using the linode script, after trying to install it using the AMP install script on the website.

I cannot using either get it to connect to a newly created instance of Minecraft. It keeps giving an error,

:Anonymous08:04:39
Failure to make API call to Jeremy (http://localhost:8081/) - retried 10 times : Connection refused
HttpRequestException
[0] (HttpRequestException) : Connection refused
at ADSModule.WebMethods.MakeInstanceRequest (m.Http.IHttpRequest request, String REQ_RAWJSON, String requesturi) at ADSModule.WebMethods.Servers (m.Http.IHttpRequest request, String id, String REQ_RAWJSON)
SocketException
[1] (SocketException) : Connection refused

I assumed this was the AuthServer not taking requests and I checked my Login Settings in the instance's AMPConfig and they are

################################
# Login
################################ Login.UseAuthServer=False
# Login.AuthServerURL - The URL for the ADS instance providing authentication when using UseAuthServer
Login.AuthServerURL=http://localhost:8080/
Login.MetricsServerPort=12820 Login.LDAPAllowAuthOnAnyDomain=False
Login.LDAPAuthDomain=

I am not doing anything not standard, its all managed by the standard things, (I mean I used the standard install scripts), not using SSL, or a URL. Just going to the "IP Address of the server":8080

Any ideas on how to help? Let me know if you need any more info.

Thanks,

Jeremy

Edit: Also its on AMP Release "Ganymede" v2.1.0.8, built 15/02/2021 14:37 And its on Debian 10

Order By: Standard | Newest | Votes
Mike posted this 15 February 2021

"Connection refused" means it's straight up not listening, does ampinstmgr status show that instance "Jeremy" is running?

Coldreactor posted this 15 February 2021

Yes, it does. It shows up running there and on the web manager.

Mike posted this 15 February 2021

Try changing the auth server URL from localhost to 127.0.0.1

Coldreactor posted this 15 February 2021

Tried that, still not working

Mike posted this 16 February 2021

Try disabling IPv6

Coldreactor posted this 16 February 2021

Disabled using

nano /etc/sysctl.conf
net.ipv6.conf.all.disable_ipv6 = 1

and rebooted. Still not working, tried restarting instance too.

Close