Changing the backup directory

  • 234 Views
  • Last Post 04 September 2019
  • Topic Is Solved
Valid posted this 02 September 2019

OS Name/Version: Windows 10 Education

Product Name/Version: AMP Pro License

Problem Description: I seem to be having some issues changing the backup directory. I read on this forum that we should alter the LocalFileBackupPlugin.kvp which I have. Problem is, it doesn't seem to work.

Actions taken to resolve so far: There were not any other instructions on the forum othern than to alter the LocalFileBackupPlugin.kvp so perhaps I am doing it wrong. If the file looks like

Limits.MaxTotalSizeMB=102400
Limits.MaxIndividualSizeMB=20480
Limits.MaxBackupCount=28
Limits.ReplacePolicy=ReplaceOldest
Limits.MaxDirectoryTraversalDepth=8
Storage.StorePath=./Backups/
Storage.OverrideOriginDirectory=False
Storage.OriginDirectory=
Storage.UseVDS=True

Then what do I alter? I have tried altering .StorePath, OriginDirectory, and OverrideOriginDirectory as both false and true. I have tried these settings separately, and together, and I'm literally just adding the full path to the folder in the secondary drive D:/Folder/Folder/ . What am I missing something? The intent is to utilize a secondary disk drive instead of my smaller SSD main drive. Also, if I do change this, would this break the backup section in the web interface?

Order By: Standard | Newest | Votes
Mike posted this 02 September 2019

You just need to change the StorePath. On Windows directories need a \ when they're absolute. You also need to stop AMP before editing the file for the given instance.

Valid posted this 04 September 2019

Thank you! Made the rookie oversight of using / instead of \ Changing this plus stopping the instance before making the change did the trick! Everything is now running smoothly and just the way it's supposed to.

Close