Console error when user try to log in

  • 665 Views
  • Last Post 08 February 2019
XXdaugonXX posted this 07 February 2019

OS Name/Version: Distributor ID: Debian Description: Debian GNU/Linux 9.7 (stretch) Release: 9.7 Codename: stretch

Product Name/Version: AMP Instance Manager v1.7.2.4 built 17/01/2019 14:20

Problem Description: Error Code

Using HTTPS: Yes

Error Code: Null Reference Object reference not set to an instance of an object

Thrown by the 'Core' plugin while performing the 'Login' method.

Related Link:

Advanced Details

at GSMyAdmin.WebServer.WebAttributes.InvokeMethod (String MethodName, Newtonsoft.Json.Linq.JObject Data, m.Http.IHttpRequest request, ModuleShared.IWebSession Session, ModuleShared.WebMethodsBase MethodsClass, String RawRequest) at GSMyAdmin.WebServer.APIService.InvokeAPI (m.Http.IHttpRequest request, ModuleShared.IWebSession Session, Newtonsoft.Json.Linq.JObject Data, String RequestModule, String RequestMethod, String RawRequest)

Order By: Standard | Newest | Votes
Mike posted this 07 February 2019

Your installation is outdated.

XXdaugonXX posted this 07 February 2019

Still same error when not using the admin user

Mike posted this 07 February 2019

What version was the user created as? And are you using ADS?

XXdaugonXX posted this 07 February 2019

v1.7.2.4 and yes

XXdaugonXX posted this 07 February 2019

Just recreated the other accounts in 1.7.2.6 and they are still getting the error

Only the admin account are able to login

(Updated Error code section with full Error code )

Mike posted this 07 February 2019

Looks like an issue that affects how the new nested permissions system works in ADS.

Give everyone the Admin role for now. Also check what the actual instance version is, not the instance manager. They're not necessarily in step.

XXdaugonXX posted this 08 February 2019

Did not work.. but the accounts work after i untick the (Need to change password) the accounts are even able to login while not having admin permissions

So looks like its somthing with the (need to change password) function

Close