Factorio Instance Refuses to start (Nightly Build)

  • Last Post 07 November 2019
  • Topic Is Solved
Ohno2 posted this 07 November 2019

OS: Windows

Name/Version: AMP Version (Nightly)

Description of issue:

I have started a Factorio instance and it is unable to start. I have added a default.zip file in the "saves directory" but have not changed any other settings. The server gives the error "could not complete action" when I try to start it. I have updated the server to the most recent version through the "Update" button and have tried F5.


[02:29:13] [APIService:ohno2 Error] : WebException

[02:29:13] [APIService:ohno2 Error] : [0] (WebException) : The remote server returned an error: (500) Internal Server Error.

[02:29:13] [APIService:ohno2 Error] : at Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)

at Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)

at Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)

at AMPAPI.RemoteInstance.d__15`1.MoveNext()

at AMPAPI.RemoteInstance.API_Core.()

at GSMyAdmin.WebServer.WebMethods.()

at GSMyAdmin.WebServer.WebAttributes.InvokeMethod(String MethodName, JObject Data, IHttpRequest request, IWebSession Session, WebMethodsBase MethodsClass, String RawRequest)

at GSMyAdmin.WebServer.APIService.InvokeAPI(IHttpRequest request, IWebSession Session, JObject Data, String RequestModule, String RequestMethod, String RawRequest)

Module: Factorio

Order By: Standard | Newest | Votes
Mike posted this 07 November 2019

AMP 1.9 has just shipped, so set up a fresh install and see if the issue persists.

Ohno2 posted this 07 November 2019

Fixed the startup issue, thank you!