File Manager Permissions Fail

  • Last Post 02 September 2019
  • Topic Is Solved
brianjd posted this 02 September 2019

I just upgraded to 1.8.50 of AMP. I do not remember when I last had access, but I am no longer able to delete, rename, or unzip files using the File Manager. It indicates permission denied or cannot access. Creating folder works fine, but once created I cannot rename or delete it.

I am running on Ubuntu 19.04 (current on updates) and have confirmed and reset permissions on Minecraft instance folder and all enclosed items. My amp user is the owner of the files, and is the group member... all with Create / Delete access. For the heck of it, I relaunched AMP with sudo and still did not have access.

I have also tried creating a new Super User in AMP, but the problem remains for that user.

Anything else I can try? Any logs or other information you would need to help me troubleshoot?


Order By: Standard | Newest | Votes
Mike posted this 02 September 2019

It's a known issue that only affects Linux systems (also you've possibly just killed your setup entirely by running it under sudo as this will immediately destroy the permissions if it actually succeeded in starting rather than seeing that it's root and killing itself).

The Nightly build has a fix for this issue.

brianjd posted this 02 September 2019

Nightly solved the problem! Permissions from when I sudo launched did not change.

Thank you. Your support is fantastic!