Garry's Mod Server Problem

  • 289 Views
  • Last Post 27 December 2020
  • Topic Is Solved
Kirschi posted this 25 December 2020

OS Name/Version: Windows 10 Pro (64 Bit)

Product Name/Version: G-Mod-Server Instance in AMP Release "Europa" v2.0.8.10, built 15/12/2020 17:08

Problem Description: I somehow can't get past the message that reads "The srcds server must be bound to a specific IP address rather than 0.0.0.0 to function correctly in AMP".

Actions taken to resolve so far: I've tried binding the instance to my local IP, to 127.0.0.1 and to my DynDNS domain. All three resulted in the main module in AMP not starting anymore after that change. I've had to delete the instance to get the main module to start again.

I've changed all IPs in the settings (starting with the Source Server IP in the Source Server Settings) to 127.0.0.1 and my local IP, unfortunately to no avail.

I'm lost, I don't know where to change the IP and to which one.

Order By: Standard | Newest | Votes
Mike posted this 25 December 2020

Delete and re-make the instance, you've probably changed the wrong thing in the process.

It should be the setting called "IP Binding" within the instance. Type that into the top-right search box, and select your machines internal IP.

Kirschi posted this 25 December 2020

Thanks for the fast answer!

Through searching "IP Binding" I've only found "RCON IP Binding" which I changed to my machines internal IP. Unfortunately that didn't work as well, even after restarting the instance. I'm still getting the same error.

Mike posted this 25 December 2020

Manage the instance -> Configuration -> Source Server Settings -> Server IP Address

Kirschi posted this 26 December 2020

Unfortunately I already tried every selectable IP to no avail in that exact menu, still the same error

Mike posted this 26 December 2020

Delete the instance and try again with a new one.

Kirschi posted this 26 December 2020

I already tried that, I deleted and recreated that instance 5 times yesterday. In 2 of those cases the instance defaulted to my local IP and in every case I first just tried starting it without changing anything (meaning in 2 of those cases the instance already had my local IP in that setting) and I always only got that error.

Kirschi posted this 26 December 2020

If there's any file I could edit to "force" the change of IP Binding, I'd be really grateful if you could tell me, doesn't matter if textfile or binary, I'm able to change both

Mike posted this 26 December 2020

Show me a screenshot of that setting with your internal IP showing, and of the error you get.

Kirschi posted this 27 December 2020

Here: https://imgur.com/a/1Kn2PRe

Mike posted this 27 December 2020

Delete the instance, then make sure that settings value is correct before hitting start.

Kirschi posted this 27 December 2020

I did, it downloaded a second update after the first and now it works. Thank you so much!

Close