I am trying to setup a csgo 1v1 server.

  • 311 Views
  • Last Post 11 January 2019
  • Topic Is Solved
lorentedford posted this 07 January 2019

So I created the server using AMP panel then started it and put in all the information I thought that was needed.. However I am trying to setup the 1v1 arena as mentioned here. I am not a pro at understanding how to start the 1v1 arena config and not sure if maybe amp was the best idea for running this.

Here is the 1v1 arena i chose to run however when the server boots up in goes to dust.. Also it seems to be moreless regular competitive then 1v1 type style.. Also I am having difficulty figuring out the workshop map side to the server.

I know not all this is amp related but was wondering if there is some sort of way to customize the start away from these panel settings..

Screen Shot of Default Server Configuration

I am a newbie when it comes to running servers so apologize if all this is not directly related to amp.

Order By: Standard | Newest | Votes
Mike posted this 07 January 2019

Well de_dust2 is the map you've selected in the top left. So you'll need to change that to whatever map you want it to run. Anything else will be part of the server config files which can be accessed via the file manager.

lorentedford posted this 07 January 2019

So I have since changed this to a workshop map what particularly needs to be done to ensure my list of workshop maps work also do i have to run a plugin to allow users to vote for the maps? Also how do you get workshop maps to work? I have created subscribed_file_ids and put that in the /csgo folder but still having issues with this.. Also I think it is stuck in Lan mode and won't come out of lan mode.

Mike posted this 08 January 2019

You'll need to obtain the workshop maps manually for now using steamcmd. My understanding is that you can vote without plugins but that's not within AMPs control so you'll need to see the documentation for the server. You need a GSLT token to run the server on the internet instead of LAN only mode.

lorentedford posted this 09 January 2019

I think the bigger issue at the moment is getting the motd and gsl panel to work inside amp..I think once we can figure out why i make changes there and it doesn't appear on the server etc..

lorentedford posted this 09 January 2019

Here is what i have for configuration. enter image description here

Here is what GameTracker is showing.......

https://www.gametracker.com/server_info/157.185.79.38:27015/

Guys the RCON PASSWORD IS FAKE!!

lorentedford posted this 10 January 2019

Here is an updated post after a format and reinstall of this server I still can't get it to change the name no matter what I do to it..

enter image description here

Any ideas on how to just change the name of the csgo server outside using the in amp portal deal?

https://www.gametracker.com/server_info/157.185.79.38:27015/

You can check the live stats above as I am testing this out trying to get it to work.

Mike posted this 11 January 2019

Resolved via Discord. AMP was specifying -hostname rather than +hostname, workaround is to use custom options for now.

Close