Instance hangs on execution - AMPBeta

  • 2K Views
  • Last Post 25 August 2017
orangepaw3 posted this 24 August 2017

OS Name/Version: Ubuntu 16.04

Product Name/Version: AMPBeta

Problem Description: I am really new to Ubuntu. My problem is: When I type: ./ampinstmgr CreateInstance ADS ADSInstance 0.0.0.0 8080 [KEY] [PASS] +Core.Login.Username AMP

The commands seem to hang. The command line goes down and the cursor just blinks without a prompt indefinitely.

I have replaced my key and password with [] variables in this post.

Actions taken to resolve so far:

  • I attempted to configure iptables.
  • I opened the port on my router.
  • I bridged my NAT from the Ubuntu VM to the windows 2016 server.
  • I baked cookies for emotional support. :-)

Thanks in advance for the help and reading.

Order By: Standard | Newest | Votes
Mike posted this 24 August 2017

If you have IPv6 enabled, try temporarily disabling IPv6.

sadumon posted this 25 August 2017

I'm basically having the same exact problem. It doesn't appear to be doing anything, even when doing a Help command or -l. It always hangs after it starts the process. I have to CTRL+C to do anything. I'm on Debian 8:

./ampinstmgr Help
[Info] AMP Instance Manager v1.4.8.2
[Debug] Starting process /sbin/ldconfig
[Debug] Working Directory: /home/mcserver/AMP
[Debug] Arguments: -p
[Debug] Started process with ID 24459

Mike posted this 25 August 2017

Download the previous version of the instance manager for now : https://cubecoders.com/Downloads/1480/ampinstmgr.zip - you can still use the latest version of AMP itself with it.

Close