Latest Nightly (v20191029.1) and FastTrack - Cannot manage instances due the version differences

  • 41 Views
  • Last Post 3 weeks ago
  • Topic Is Solved
AbhorrentJoel posted this 3 weeks ago


Update 1:

Looks like this issue also impacts the latest FastTrack version (v1.9.0.0, built 30/10/2019 03:00), too. The quick 'n' dirty fix is to manually modify the "AMPVersion" file for the individual instances to "1.9.0.0" since these are actually 1.9.0.0 but the file states 1.8.8.0. Whatever is creating the "AMPVersion" file is not putting the correct version.


OS/Release: Ubuntu 18.04.3 LTS

Product Name/Version: AMP v20191029.1 (Nightly)

Problem Description: The release stream for ADS instance was switched to Nightly from Mainline and upgraded. ADS and all new instances created are running v20191029.1 yet I am unable to manage the instances. Message given is as follows:

This instance is not the same version as this ADS installation. ADS is version 1.9.0.0 but this instance is version 1.8.8.0

Steps to reproduce:

  • Stop ADS instance and switch from Mainline to Nightly
  • Upgrade and start ADS instance
  • Ensure release stream is "Nightly" in New Instance Defaults
  • Create new instance for an application
  • Start and attempt to manage new instance

At this point, you should not be able to manage the new instance due to the ADS version being recognised as 1.9.0.0 (even though the version in AMPVersion was 1.8.8.0) but the application instance being 1.8.8.0.

Actions taken to resolve so far:

  • All instances were upgraded using "upgradeall" and also individually upgraded without any change to the outcome.
  • All instances (other than ADS) were deleted and recreated and also manually upgraded after as a precaution - no change.

I am pretty certain that the instances being created were using the Nightly stream, but the main ADS seems to see the application instances as being older. Currently using FastTrack after this with the Nightly release being selected for new instances without any issues managing it - and I know the Nightly in this case is being used since it has the recently incorporated changes to the SevenDays module.

Not a biggy, since I understand the nature of the Nightlies. I just wanted to take advantage of a few fixes. For now I am just using FastTrack for the ADS and Nightlies for instances that benefit from the fixes/changes.

Order By: Standard | Newest | Votes
Mike posted this 3 weeks ago

It's a known issue for anything that's not the Mainline build. Non-mainline builds do not have any version metadata, so this isn't something that's going to get fixed for now. It only happens when the nightly version number jumps ahead of Mainline which it normally only does very shortly before a release.

AbhorrentJoel posted this 3 weeks ago

I suppose it is safe and reasonable for me to manually adjust the version in the "AMPVersion" file given that the versions are actually presented as 1.9.0.0? Management is not otherwise possible.

Your wording makes me believe a Mainline release is imminent. Is this correct?

Mike posted this 3 weeks ago

Correct on both counts.

AbhorrentJoel posted this 3 weeks ago

Cool. I'll just mark it as solved for now since there is a temporary solution and there is an awareness of the issue.

Close