McMyAdmin2 - Backup manifest not including world

  • 54 Views
  • Last Post 29 March 2019
  • Topic Is Solved
mcadminuser1023 posted this 28 March 2019

OS Name/Version: Windows 10 Education Version - 64 bit

Product Name/Version: McMyAdmin v2.7.1.0 Personal

Problem Description: I take a manual backup of a server, and get a .mb2 file. The web interface shows these files not taking any space. I am concerned files aren't being backed up. Upon unzipping the .mb2 files, it appears they only include a manifest file. The 'worlds' array of this manifest.json is empty, which is probably the culprit. I can't figure out how to make McMyAdmin actually populate this field, and thus backup my world folder.

Steps to reproduce: Take a backup. Unzip the .mb2, only a manifest.json is there.

Actions taken to resolve so far: Have tried finding where to add my world to the backup system but cannot find it.

mcadminuser1023 posted this 29 March 2019

I figured it out. I went to Configuration->World Management and noticed that when I clicked on my world folder, it said it was a "child of 'worlds'". "worlds" was a folder I made in the Minecraft folder. I added my world to this, but later put it back into the Minecraft folder. I guess it never updated when I pulled it out of "worlds". Regardless, it was probably my fiddling with the directory structure. To fix it, I pulled the world folder I was having trouble with out of Minecraft, scanned for worlds, and then put it back into the Minecraft folder. This can be closed.

Close