Migrated from McMyAdmin to AMP, cannot connect to server anymore

  • 41 Views
  • Last Post 4 weeks ago
  • Topic Is Solved
Valrek777 posted this 4 weeks ago

OS Name/Version: Windows 10 version 10.0.18363 Build 18363

Product Name/Version: AMP v1.9.9.10 "Lapetus"

Problem description:

I was importing my server from McMyAdmin to AMP, following these instructions (https://github.com/cubecoders/amp/wiki/How-to-import-an-existing-Minecraft-server-into-AMP)and I cannot connect to the server at all unless I use direct connect 192.xxx.x.x:25565. If I or anyone else tries to connect in any other way, this error message pops up via minecraft: io.netty.channel.abstractchannel$annotatedconnectexception: connection timed out: no further error

Steps to reproduce:

Create functional minecraft server in McMyAdmin Follow steps in https://github.com/cubecoders/amp/wiki/How-to-import-an-existing-Minecraft-server-into-AMP exactly Atempt to connect via minecraft (doesn't work) Connect via local IPv4 address (works)

Actions taken to resolve so far:

I see no errors from AMP stating anything is wrong on that end. I've tried going into the Configuration>SMTP Settings menu and typing in my public IP as the server address and 25565 as the server port.

I don't know what else to do/don't want to mess with anything further in case I make it worse. Any help is appreciated!

Order By: Standard | Newest | Votes
Mike posted this 4 weeks ago

Either your firewall or port forwarding rules are wrong. https://github.com/CubeCoders/AMP/wiki/Diagnosing-Connectivity-Issues

  • Liked by
  • Valrek777
Valrek777 posted this 4 weeks ago

EDIT: I typed in the wrong IP for the port forwarding, you were right! Just took me a while to see it. Thank you very much!

I ran ampinstmgr ports 'Instancename' and here is the result:

Microsoft Windows [Version 10.0.18363.900] (c) 2019 Microsoft Corporation. All rights reserved.

D:\AMPDatastore\Instances\ADS01>ampinstmgr ports Minecraft01 [Info] AMP Instance Manager v1.9.9.10 built 23/06/2020 23:20 [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV [Info] Port usage for Minecraft01 (Minecraft01) [Info] Instance is currently not running. [Info] LISTENING 8081 TCP (Core.Webserver.Port) [Info] CLOSED 25565 Both
(MinecraftModule.Minecraft.PortNumber) [Warning] Some of the ports required by this instance are currently in use, which will prevent this instance from functioning correctly.

D:\AMPDatastore\Instances\ADS01>

I don't understand how to see what's using the port or how to change that.

Close