Minecraft Forge 1.13.2 console output is not UTF-8

  • 167 Views
  • Last Post 25 April 2019
Aglesia posted this 18 April 2019

Hello, I'm using Minecraft Forge with AMP, and it works fine.

But the console output is weird, so AMP can't extract data an think the server is starting infinitly... And AMP can't see the events from the console, like connection of an user.

Exemple of output :

11:50:351:50:35.090] [main/INFO] [Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 25.0.147, --fml.mcpVersion, 20190213.203750, --fml.mcVersion, 1.13.2, --fml.forgeGroup, net.minecraftforge, nogui]
1:50:35.093] [main/INFO] [Launcher/MODLAUNCHER]: ModLauncher starting: java version 1.8.0_201
1:50:35.267] [main/INFO] [loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
1:50:35.718] [main/INFO] [LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlserver' with arguments [--gameDir, ., nogui]
11:50:46 : 1:50:46.258] [main/INFO] [crafting.RecipeManager/]: Loaded 0 recipes
1:50:46.302] [Server thread/INFO] [dedicated.DedicatedServer/]: Starting minecraft server version 1.13.2
1:50:46.350] [Server thread/INFO] [ModLoader/CORE]: Loading Network data for FML net version: FML2
1:50:46.542] [modloading-worker-3/INFO] [ForgeMod/FORGEMOD]: Forge mod loading, version 25.0.147, for MC 1.13.2 with MCP 20190213.203750
1:50:46.542] [modloading-worker-3/INFO] [MinecraftForge/FORGE]: MinecraftForge v25.0.147 Initialized
1:50:47.321] [Forge Version Check/INFO] [VersionChecker/]: [corpse] Starting version check at https://maxhenkel.de/update/corpse.json
1:50:47.328] [Server thread/INFO] [dedicated.DedicatedServer/]: Loading properties
1:50:47.345] [Server thread/INFO] [dedicated.DedicatedServer/]: Default game type: SURVIVAL
1:50:47.345] [Server thread/INFO] [dedicated.DedicatedServer/]: Generating keypair
1:50:47.704] [Server thread/INFO] [dedicated.DedicatedServer/]: Starting Minecraft server on 192.168.1.107:25565
1:50:47.903] [Server thread/INFO] [NetworkSystem/]: Using epoll channel type
11:50:48 : 1:50:48.066] [Forge Version Check/INFO] [VersionChecker/]: [corpse] Found status: UP_TO_DATE Target: null
1:50:48.067] [Forge Version Check/INFO] [VersionChecker/]: [servertabinfo] Starting version check at http://myurl.me/
[11:50:48.468] [Thread-1/FATAL] [ForgeConfig/CORE]: Forge config just got changed on the file system!
[11:50:48.468] [Thread-1/FATAL] [ForgeConfig/CORE]: Forge config just got changed on the file system!
1:50:48.495] [Server thread/INFO] [dedicated.DedicatedServer/]: Preparing level "world"
1:50:48.613] [Server thread/WARN] [FMLWorldPersistenceHook/WP]: This world was saved with mod forge version 25.0.100 and it is now at version 25.0.147, things may not work well
1:50:48.625] [Server thread/INFO] [GameData/REGISTRIES]: Injecting existing registry data into this SERVER instance
1:50:48.996] [Server thread/INFO] [SimpleReloadableResourceManager/]: Reloading ResourceManager: ServerTabInfo-1.13.2-1.2.4-beta.jar, forge-1.13.2-25.0.147-universal.jar, corpse-1.13.2-1.0.5.jar, Default
11:50:49 : 1:50:49.055] [Forge Version Check/INFO] [VersionChecker/]: [forge] Found status: BETA Target: null
11:50:50 : 1:50:50.331] [Server thread/INFO] [crafting.RecipeManager/]: Loaded 524 recipes
11:50:51 : 1:50:51.524] [Server thread/INFO] [AdvancementList/]: Loaded 571 advancements
1:50:51.947] [Server thread/INFO] [MinecraftServer/]: Preparing start region for dimension minecraft:overworld
11:50:52 : 1:50:52.281] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 4%
1:50:52.479] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 20%
1:50:52.996] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 100%
1:50:52.996] [Server thread/INFO] [MinecraftServer/]: Time elapsed: 1049 ms
1:50:52.997] [Server thread/INFO] [dedicated.DedicatedServer/]: Done (4.622s)! For help, type "help"

Every lines starts with "1", and not "[11" :(

Order By: Standard | Newest | Votes
Aglesia posted this 25 April 2019

In SSH, their is no change, log is always colorfull

/usr/bin/java -Xmx5120M -jar forge-1.13.2-25.0.100.jar nogui -nojline --log-strip-color

In AMP with "Custom" server type :

Last Executable /usr/bin/java
Last Arguments  -Xmx5120M -jar forge-1.13.2-25.0.100.jar nogui -nojline --log-strip-color

Console output :

13:46:58
3:46:58.660] [main/INFO] [Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 25.0.100, --fml.mcpVersion, 20190213.203750, --fml.mcVersion, 1.13.2, --fml.forgeGroup, net.minecraftforge, nogui, -nojline, --log-strip-color]
3:46:58.663] [main/INFO] [Launcher/MODLAUNCHER]: ModLauncher starting: java version 1.8.0_191
3:46:58.821] [main/INFO] [loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
13:46:59
3:46:59.408] [main/INFO] [LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlserver' with arguments [--gameDir, ., nogui, -nojline, --log-strip-color]

Same :(

AMP always show "Server starting" notification, can't extract data from logs and don't see any event :(

I will test many things in SSH while the logs are colofull, I think is not an AMP issue...

Why don't use "tail -f latest.log" to get output ? their is no color on the logfile...

Mike posted this 25 April 2019

I mean when running it manually outside of AMP. "Custom startup arguments" requires using the "Custom" server type and specifying a complete set of Java flags (xms, xmx, -jar etc)

Aglesia posted this 25 April 2019

How to add parameters to the end ?

If I write it in 'Configuration -> Java -> Additional java options' :

Last Executable /usr/bin/java
Last Arguments  -Xmx5120M -nojline --log-strip-color -jar forge-1.13.2-25.0.100.jar nogui

Console :

11:34:57 Unrecognized option: -nojline
         Error: Could not create the Java Virtual Machine.
         Error: A fatal exception has occurred. Program will exit.
11:35:26 Unrecognized option: --log-strip-color
         Error: Could not create the Java Virtual Machine.
         Error: A fatal exception has occurred. Program will exit.

If I write it in 'Configuration -> Minecraft -> Custom startup arguments' :

Last Executable /usr/bin/java
Last Arguments  -Xmx5120M -jar forge-1.13.2-25.0.100.jar nogui

Console :

11:35:46
1:35:46.178] [main/INFO] [Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 25.0.100, --fml.mcpVersion, 20190213.203750, --fml.mcVersion, 1.13.2, --fml.forgeGroup, net.minecraftforge, nogui]
1:35:46.181] [main/INFO] [Launcher/MODLAUNCHER]: ModLauncher starting: java version 1.8.0_191
1:35:46.336] [main/INFO] [loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
1:35:46.807] [main/INFO] [LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlserver' with arguments [--gameDir, ., nogui]

I Think 'Custom startup arguments' is not used :/

Mike posted this 25 April 2019

Try adding -nojline --log-strip-color to the end.

Aglesia posted this 24 April 2019

Can the Java version be the problem ?

AMP@ubuntu:~$ java -version
java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)

EDIT : Nope... Just changed to openjdk-8-jre, same issue...

AMP@ubuntu:~$ java -version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-2ubuntu0.16.04.1-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

Aglesia posted this 24 April 2019

The return is "xterm 256color"

AMP@ubuntu:~$ echo $TERM
xterm-256color

Mike posted this 24 April 2019

What's the output of echo $TERM ?

Aglesia posted this 24 April 2019

Hi,

I've just tested this command via SSH :

AMP@ubuntu:~/.ampdata/instances/Minecraft01/Minecraft$ /usr/bin/java -Xmx5120M -Djline.terminal=jline.UnsupportedTerminal -jar forge-1.13.2-25.0.100.jar nogui

The output is realy good, with colors and date, but when I type "/test" command :

/test
[13:43:45.118] [Server thread/INFO] [dedicated.DedicatedServer/]: §cUnknown command§r
[13:43:45.120] [Server thread/INFO] [dedicated.DedicatedServer/]: §7/§r§c§ntest§r§c§o--[here]§r

"§7/§r§c§n"... even with "-Dfile.encoding=UTF-8" parameter

Aglesia posted this 24 April 2019

My current locale :

LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8
LC_ALL=

Mike posted this 23 April 2019

I can't reproduce this issue. I'm guessing you're on Linux? If so what's your system locale set to?

Aglesia posted this 23 April 2019

Hi,

Just updated AMP to 1.7.4.4, and same things :'(

Aglesia posted this 18 April 2019

Add in 'configuration -> java -> additionnal java options', and reload the server :

Last Executable /usr/bin/java
Last Arguments  -Xmx5120M -Djline.terminal=jline.UnsupportedTerminal -jar forge-1.13.2-25.0.100.jar nogui

Go to the console, and...

14:47:07 : 4:47:07.563] [Server thread/INFO] [AdvancementList/]: Loaded 571 advancements
4:47:07.979] [Server thread/INFO] [MinecraftServer/]: Preparing start region for dimension minecraft:overworld
14:47:08 : 4:47:08.427] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 4%
4:47:08.513] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 8%
4:47:08.621] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 12%    
4:47:08.790] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 16%
4:47:08.901] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 20%
4:47:08.962] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 24%
14:47:09 : 4:47:09.031] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 28%
4:47:09.074] [Server thread/INFO] [MinecraftServer/]: Preparing spawn area: 32%

Same :(

Mike posted this 18 April 2019

Try adding the follow to the custom java flags setting:

-Djline.terminal=jline.UnsupportedTerminal

Aglesia posted this 18 April 2019

Hi,

I've got a NAS (just a computer) using FreeNas OS.

In this NAS (I3-7100T, 16GB DDR4, 6TB HDD), i created a VM with Ubuntu 16.04 LTS with 40 GiB HDD and 6 GB RAM.

In this fresh install VM, I installed AMP 1.7.3.5 with the script :

sudo su -c "bash  (wget -qo- https://cubecoders.com/getamp.sh)"

i created an instance with minecraft java edition (memory limit for java : 5120 MB) and in 'configuration -> Minecraft' :

Server Type : Forge
Release Stream : Specific Version
Forge Version : 25.0.100 (mc 1.13.2)
Server JAR : forge-1.13.2-25.0.100.jar

When I select "Server JAR : minecraft_server.1.13.2.jar", everything is fine, but I can't load mods.

With Forge, I can load mods, but the console output is strange (like my example), even with no mod. Just to be sure, i tested with the latest version of Forge (25.0.147), but the problem is the same :(

(Sorry for my bad english, I'm french ^^)

Mike posted this 18 April 2019

The ANSI colour codes are being left in. Are you using custom mode or a preset server type?

Close