Minecraft module not fully working

  • 661 Views
  • Last Post 25 June 2019
  • Topic Is Solved
Dymas_CZ posted this 18 June 2019

OS Name/Version: Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-52-generic x86_64) New installation on new HW

Product Name/Version: AMP Release "TITAN" v1.8.1.4, built 18/06/2019 09:23

Problem Description: Missing parts of configuration and cant controll server. Missing part can be seen in screenshot. Tested on multiple instances of Minecraft, other modules working without problems. Logs contain no error messagess. Tested on Chrome and Firefox with anonymous mode to ensure thet it is not a browser extention problem.

Screenshot of problem https://ibb.co/DG5JRYn

Steps to reproduce: Login to AMP and Manage Minecraft instance or direct to Minecraft Click on "Configuration"

Actions taken to resolve so far: Reinstall Minecraft instance, reinstal whoule AMP, check if ADS and Minecraf instance and ampinstmgr have same wersion.

Order By: Standard | Newest | Votes
Mike posted this 19 June 2019

If you access the Minecraft instance directly on its own port instead of via ADS, does it function correctly?

Dymas_CZ posted this 19 June 2019

I can access it on its own port but nothing changes. Cant controll or setup the server as stated before.

Mike posted this 19 June 2019

Okay, in that window separately if you do CTRL+F5 does anything change? I'm assuming you're logging in with your primary admin user.

Dymas_CZ posted this 19 June 2019

Yes no change im using the main Admin account but i tested creating a superadmin account for the specific instance with the same outcome.

mark.monteiro posted this 19 June 2019

I am also experiencing the same issue, we went through some troubleshooting on the Discord chat yesterday. I'm adding a summary of the the things we confirmed/tried yesterday:

  • Ctrl+f5 in front-end and a full browser cache clear
  • Confirmed there are no errors in the front-end console log
  • Instances are all on the mainline release stream
  • Confirmed that all server instances and the ampinstmgr command line tool are up to date
  • build date (bottom left corner) for ADS and the Minecraft instance match

I have also gone through the troubleshooting steps in the comments above with he same results as Dymas_CZ

Yabdat posted this 19 June 2019

I have the same issue. I run 5 different minecraft servers, and all of them have this problem.

I got my vanilla minecraft server, perhaps by chance, to give me the normal AMP screen. I could start the server and everything, but when I refreshed the page it went back to the bugged out version. No difference in the logs between the now bugged server and any of the others.

Mike posted this 19 June 2019

Okay, I can't currently reproduce this with the Minecraft instance. Is there anything showing in the Console tab of the F12 developer console? You should open it before logging in.

Yabdat posted this 19 June 2019

This is what I got.

https://imgur.com/a/atlCb5z

Mike posted this 19 June 2019

Can you email me a set of login details? (contact@)

cesjr1965 posted this 20 June 2019

I am having the same problem. Can't control server and missing parts of configuration

sithrebel15 posted this 20 June 2019

Just wanted to mention I have the same issue. i'm happy to provide nay information that can help and can give any logs, a web login or shell access on my test server if any of it will help. I believe this started with 1.8.1 but i'm not 100% sure what version i was on before updating.

Dymas_CZ posted this 20 June 2019

After reinstalling the server and updating the OS i installed AMP again and this time Minecraft module is working. I wonder if this could be a problem with some shared libs. Will install my other applications i need on my server and will test if MC module is working.

Mike posted this 20 June 2019

I need someone to send me a set of login details to an instance behaving like this so I can examine it.

cesjr1965 posted this 20 June 2019

Sorry, what do you mean by login details. I can send you some with more info. Thanks

Mike posted this 20 June 2019

Just a web address, username and password for an AMP panel that has this problem.

Yabdat posted this 20 June 2019

Sent login details to one of my servers, AMP is usually not open to the inet, but should be working now.

Yabdat posted this 20 June 2019

Btw, I got this when I tried to click on the Spiggot Plugins tab.

https://imgur.com/a/IbLw2eI

cesjr1965 posted this 20 June 2019

I can give you login information privately but would need to setup some also

Dymas_CZ posted this 21 June 2019

After some testing figured out it was a problem with openjdk. Tested with openjdk 8 and 11. When installing one of openjdk version on my system the Minecraft module did not work. Using Oracle Java this prublem is not present.

Yabdat posted this 21 June 2019

Hmm, that does not help me. I am using Oracle Java not openjdk, and I still have the problem.

EDIT: Tried switching to Oracle Java11, still same problem.

Show More Posts
Close