Missing Multiverse-Portals Spigot Plugin - How to install it?

  • 64 Views
  • Last Post 1 weeks ago
damago1 posted this 2 weeks ago

Hello, I have just installed AMP and I am trying to setup a server with mutiple worlds. There is a Multiverse-Core plugin available out of the box but Multiverse-Portals plugin is missing from Spigot Plugins menu.

How can I update the list to include the rest of Multiverse plugins package?

Or if it is not possible is it safe to install plugins manually? If so how to do this safely?

I have purchased AMP to do a trouble free installation and I am a bit dissapointed.

Order By: Standard | Newest | Votes
KILOFOXTROT posted this 2 weeks ago

The amount of Spigot plugins is massive, therefore not all of them will show up on the AMP interface. To install Multiverse Portals: Download the .jar file. Drag and drop it in to the Minecraft/Plugins folder in the AMP Filemanager

isikerkan posted this 2 weeks ago

Please don't blame AMP for something, that others cause. AMP is a Server Manager and the Spigot Plugin installer is a great Feature to have, but in this regard you should blame the Creator of the Mutliverse Plugin for not publishing it on Spigot.

The old Bukkit installer was abadoned a long time ago, because it was broken and hard to maintain. Also CubeCoders only advertises the Spigot Plugin installer, they have no support for the Bukkit Site.

The Multiverse Portal Developer doesn't activly Support the Plugin and it's incompatible with Version 1.15.2.

They only published it on Bukkit: (Sadly I cant post a bukkit link, you need to search it yourself)

  1. Download the Plugin or a Devbuild from Bukkit
  2. Upload it to the Minecraft Server with the Filemanager
  3. Restart the Server

P.S. This is my own opinion and Im not affiliated with CubeCoders. Feel free to Blame me :) There is a unofficial Build on Spigot, search for Multiverse Portal.

Mike posted this 2 weeks ago

The above comments pretty much answer this. If a developer doesn't publish a plugin on Spigot Resources then it won't show up in AMP, that's a decision purely down to the plugin developer that we have no control over. You'll need to fetch it yourself and drag+drop it into the plugins directory in the file manager.

damago1 posted this 1 weeks ago

One remark from my side: 1) I have managed to make it work. I had to download all multiverse components directly from Bukkit site (NO SPIGOT!) after a long research it turned out that all multiverse information on Spigot site is incomplete and outdated. I had to manually upload multiverse-core and multiverse-portals found on bukkit via file manager. They are not for Spigot but they work ok with Spigot.

BUT:

2) Main reason for me to buy a licence of AMP was to have a kind of curated, tested environment to effortlessly install 2 minecraft servers. My hope was, that I will be able to more or less plug-and-play (at least fully from GUI) install a simple multiverse server, add basic plugins and import worlds. My imagination was, that AMP is a kind of environment where you can configure everything from GUI, including the plugins which are tested to work with the server.

What i found is that even on a builtin AMP list of plugins there is a huge mess. There is a bunch of incompatible with each other options of Multiverse, with no clear indication which should be installed for each version of Minecraft server etc. This did not help me at all.

To make things worse: I could NOT ununstall from GUI the plugins I did install from GUI. The uninstallation did not work at all. Maybe because I did install 2 different multiverse versions but I am not sure this is the case. I did ssh to the server and manually "rm *" the plugins.

So my overall feeling is that the purchase did not achieve the main goal. Treat it as a user feedback to take into account when planning a roadmap for next moves.

Mike posted this 1 weeks ago

I don't think expecting AMP to be responsible for the quality of 3rd party plugins is a particularly realistic goal. Maybe the actual path is to make it much more clear to the user that the plugin listings have nothing to do with CubeCoders and it's just showing you what's on the Spigot Resources site.

Close