Network port occupied, can't start server

  • 252 Views
  • Last Post 14 July 2020
  • Topic Is Solved
Slothy2046 posted this 14 July 2020

OS Name/Version: Ubuntu 18.04.4 LTS (GNU/Linux 5.3.0-1032-azure x86_64)

Product Name/Version: AMP Release "Lapetus" v2.0, built 10/07/2020 21:34

Problem Description: creating a 2nd Minecraft Instance (survival mode) but it is not setting up the correct port on game start.

Error instance - Survival Minecraft - port set to 25564 Console output 12:04:55 Starting Server Version 1.16.1.2 Session ID fbf3a1ad-d994-48ed-8a83-b3efb86e0714 Level Name: Land Of Doom Game mode: 0 Survival Difficulty: 2 NORMAL opening worlds/Land Of Doom/db 12:04:58 IPv4 supported, port: 0 IPv6 supported, port: 0 ERROR 12:04:58 Network port occupied, can't start server.

Working Instance - Creative Minecraft - Port set to 25566 Console output 11:50:45 Starting Server Version 1.16.1.2 Session ID 1830401b-2fc8-4b05-8fa6-12f2d0cd6abb Level Name: world Game mode: 1 Creative Difficulty: 0 PEACEFUL opening worlds/world/db 11:50:50 IPv4 supported, port: 25566 IPv6 supported, port: 19133 IPv4 supported, port: 19132 IPv6 supported, port: 43261 11:50:51 Server started.

Steps to reproduce: Step 1 - we have tried setting different ports still wants to set to 0 Step 2 - new instance

Actions taken to resolve so far: we have tried setting different ports still wants to set to 0 rebooted server (as we had just updated system and AMP server to V2

Order By: Standard | Newest | Votes
Mike posted this 14 July 2020

Its a bug in the Bedrock server. Changing the ipv6 port in server.properties solves it.

Slothy2046 posted this 14 July 2020

just trying that now, can it be set to anything or should I just remove the line?

Slothy2046 posted this 14 July 2020

Its a bug in the Bedrock server. Changing the ipv6 port in server.properties solves it.

Spot on - why could I not find this simple answer to begin with.

Close