Space Engineers Instance won't start

  • Last Post 19 September 2017
  • Topic Is Solved
Alradas posted this 18 September 2017

I bought AMP a few months ago, mainly to host two minecraft-servers. They are working perfectly, the instances are fine and I can manage everything nicely over my browser from whereever I want to.

Now a few friends of mine and I want to play space engineers on a private server. I selected the "Space Engineers" Instance option and created a new instance. It won't start, though.

I tried deleting and recreating it, suspending it, updating it, nothing works. I click on "Start Instance" and nothing happens.

Then I tried the same in my server console. I got into my AMP-Account on my server and into the AMP-Folder. After that, I made the following commands:

AMP@Alradas:~/AMP$ ./ampinstmgr StartInstance SpaceEngineers
[Info] AMP Instance Manager v1.4.7.2
[Debug] Loading instances from /home/AMP/.ampdata/instances.json...
^[[A[Debug] Loaded 4 instances.
[Info] Starting Instance: 'SpaceEngineers'
[Debug] Running /usr/bin/tmux -f /dev/null new-session -s "AMP_SpaceEngineers" -d "cd '/home/AMP/.ampdata/instances/SpaceEngineers' --; /home/AMP/.ampdata/instances/SpaceEngineers/AMP_Linux_x86_64 "
[Debug] Starting process /usr/bin/tmux
[Debug] Working Directory: /home/AMP/.ampdata/instances/SpaceEngineers
[Debug] Arguments: -f /dev/null new-session -s "AMP_SpaceEngineers" -d "cd '/home/AMP/.ampdata/instances/SpaceEngineers' --; /home/AMP/.ampdata/instances/SpaceEngineers/AMP_Linux_x86_64 "
[Debug] Started process with ID 7302
[Info] You can now browse to this instances web interface at its IP address and port.
[Info] Instance started in new session. Run './ampinstmgr Attach SpaceEngineers' to view this instances console.

AMP@Alradas:~/AMP$ ./ampinstmgr Attach SpaceEngineers
[Info] AMP Instance Manager v1.4.7.2
[Debug] Loading instances from /home/AMP/.ampdata/instances.json...
[Debug] Loaded 4 instances.
[Notice] SpaceEngineers is not running.

Between the two commands is a delay of a few seconds at most.

Is there somebody who can help me with my presumably pretty easy problem?

My Server is a linux-server, I have currently 8GB RAM and 100GB Datastorage

Order By: Standard | Newest | Votes
Mike posted this 18 September 2017

The Space Engineers developers don't ship a Linux version of the server. They only make a server for Windows, so you have to run AMP on Windows if you want Space Engineers.

  • Liked by
  • Alradas
Alradas posted this 19 September 2017

Okay, thanks anyways I guess