Struggling to set up Mods on server

  • 126 Views
  • Last Post 20 September 2021
Hallow posted this 20 September 2021

The Mod I am trying to set up on the server requires the ability to upload DLL files, and it appears that I am uploading the mod correctly, but according to the mod maker, It requires you to be able to upload DLL files, and the error I am receiving when joining the server is saying that the mod was installed incorrectly, and one of the only ways this could possibly happen is if AMP and CubeCoders don't allow uploading of DLL files.

Does AMP and CubeCoders allow uploading of DLL files? If so, do you by chance know what I could be doing wrong?

Order By: Standard | Newest | Votes
packetnarc posted this 20 September 2021

Can you please post the information on which Mod you're trying to install so we can help you ?

If you're trying to upload via filemanager / SFTP you likely don't have that file type specified in the fileManagerPlugin.kvp settings.

The default setting is:

Security.UploadableExtensions=["yml","json","txt","conf","cfg","dat","mca","png","log","gz","jar","xml","craft","schematic","config","map","zip","lua","csv","ini","mod"]

You need to go into this list and put ,"dll" in there somewhere if the dll is truly needed.

Mike posted this 20 September 2021

Easiest thing to do is to upload the server as a .zip and then extract it in AMP. Ideally use AMPs built in SFTP server to upload it.

UploadableExtensions only applies if Restrict unloadable extensions is turned on - by default this setting is turned off.

  • Liked by
  • packetnarc
Close