Trying a fresh install - minecraft bedrock won't start

  • 148 Views
  • Last Post 21 October 2020
  • Topic Is Solved
Scott posted this 17 October 2020

I was having issues with upgrading my instance to the current version so decided to try a clean install. (I used the automated install)

I went through the standard setup, created a new minecraft bedrock instance and started it. Then I manage the instance, and hit update. After update I hit start, but then it gets strange. It essentially just goes into an unusable/unchangeable state without stopping the full instance. On the status page, it just shows 0's and the graphs across the page with no controls at all. The console screen stays completely blank.

When checking the logs, I find this error:

[Minecraft:admin Error] : Process configuration failed. Target jar file has not been specified or could not be automatically detected.

What changed such that the jar fine can't be detected? In the config, it's still set to autodetect.

Thanks!

Order By: Standard | Newest | Votes
Mike posted this 17 October 2020

Can you try:

  • Changing the server type to 'official'
  • Letting it install/update
  • Changing the server jar to the minecraft_server.jar
  • Changing the server type back to 'Bedrock'

Scott posted this 17 October 2020

Hi Mike,

When I change to official, change the jar etc, it fires up and works as expected.

Changing it back to Bedrock has the previously mentioned issues whether manually selecting the minecraft_server.jar or autoselect

So it's definitely Bedrock related, but I'm at a loss for why.

Mike posted this 18 October 2020

I'll have to take a look at this on Monday.

  • Liked by
  • Scott
Scott posted this 18 October 2020

Thanks Mike. If it's helpful, I restored an old snapshot and found the same behavior in 2.0..6.8, so it's not just the current version.

Scott

Mike posted this 19 October 2020

Run

ampinstmgr --nocache upgrade INSTANCENAME

Where INSTANCENAME is the name of the Minecraft instance.

Scott posted this 19 October 2020

Mike, thank you!

That was the issue. I was able to make both the new test install and the upgraded version of my server work by doing this. Why wouldn't the new one be upgraded by default? Did I miss something?

Thanks again!

BlkKnight posted this 20 October 2020

Previous thread deleted with more detail Just so I understand what I'm supposed to be doing here.

In console I am typing: ampinstmgr --nocache upgrade Minecraft01

I still get the following error when starting my instance

Could not complete action.

Process configuration failed. Target jar file has not been specified or could not be automatically detected.

BlkKnight posted this 20 October 2020

Am I correct in that I need to run: ampinstmgr --nocache upgrade Minecraft01 from the console?

[13:10:35] [System:amp Activity]  : Sent to console: ampinstmgr --nocache upgrade Minecraft01 [13:10:35] [Minecraft:amp Error]  : Failed to write to Minecraft server STDIN stream. Server process will be killed (if it isn't already dead) [13:10:35] [Core:amp Error]       : NullReferenceException [13:10:35] [Core:amp Error]       : [0] (NullReferenceException) : Object reference not set to an instance of an object. [13:10:35] [Core:amp Error]       : at MinecraftModule.MinecraftApp.WriteLine(String message)

Starting the server: [13:11:28] [Core:Anonymous Activity] : Authentication attempt for user amp from 127.0.0.1 [13:11:28] [Core:Anonymous Activity] : Authentication success [13:11:32] [System:amp Activity]  : Starting the application. [13:11:32] [Minecraft:amp Error]  : Process configuration failed. Target jar file has not been specified or could not be automatically detected.

Mike posted this 20 October 2020

You run it from a command prompt.

BlkKnight posted this 21 October 2020

Runnin Win32, where does ampinstmgr.exe reside?

/edit never mind found it

Close