Trying to migrate my PO3 server

  • 20 Views
  • Last Post 2 weeks ago
venom posted this 2 weeks ago

Hey ya'll! so i'm running into an issue with migrating my PO3 modpack fro mcmyadmin2 to AMP. I'm running linux mint and trying to copy over the files to AMP, everytime i do so and run the server i get met with

We appear to be missing one or more essential library files.
You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch

the weird thing is.. that i can start the modpack through a regular start script and have it function no problem.

I've made sure that the AMP instance is indeed specified to run that particular forge version. Whether i install the forge version fresh through amp or copy it manually it still seems to give me the error.

Any help would be greatly appreciated!

Order By: Standard | Newest | Votes
Mike posted this 2 weeks ago

How did you manually copy it?

venom posted this 2 weeks ago

Hey Mike! So I was just copying it from one location to another on the machine AMP is installed on.

I did figure out that it was a permission based problem my solution was to use chown -R amp:amp directory of instance to transfer ownership of all the files to amp. It has at least fixed my problem of AMP throwing errors that it cannot start the server

Mike posted this 2 weeks ago

You should use AMPs built in SFTP to move files around, it's the 'server' icon in the file manager at the top.

Close