Unable to login with https - continues to spin and throws error

  • 338 Views
  • Last Post 05 January 2020
  • Topic Is Solved
ncontorno posted this 05 January 2020

I have an instance setup and am trying to activate https. I ran the command to do it automatically and updated the auth server on each of the instances. I also synced the certs as well. When I try to login, it continues to spin and then spits out the following message:

Login server unreachable. Verify that the auth server URL in this instances config file is valid.

I checked the amp log and this is what is showing:

[19:02:28] [Core:Anonymous Error] : WebException
[19:02:28] [Core:Anonymous Error] : [0] (WebException) : The operation has timed out.
[19:02:28] [Core:Anonymous Error] :   at Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) 
  at Net.WebClient.GetWebResponse (Net.WebRequest request, IAsyncResult result) 
  at Net.WebClient.GetWebResponseTaskAsync (Net.WebRequest request) 
  at Net.WebClient.DownloadBitsAsync (Net.WebRequest request, IO.Stream writeStream, ComponentModel.AsyncOperation asyncOp, Action`3[T1,T2,T3] completionDelegate) 
  at AMPAPI.RemoteInstance.GetResponseDynamic (String Module, String Method, Object Parameters) 
  at AMPAPI.RemoteInstance+API_Core.Login (String username, String password, String token, Boolean rememberMe) 
  at GSMyAdmin.Authentication.RemoteAMPAuth.Authenticate (m.Http.IHttpRequest Request, String Username, String Password, String Token, Boolean TokenRequested, Collections.Generic.List`1[String]& Permissions, String& NewToken, GSMyAdmin.Authentication.UserInfoSummary& UserInfo) 
[19:02:28] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user mc@8bf8934d-075a-44a3-b665-ffce58b8f663@8bf8934d-075a-44a3-b665-ffce58b8f663@8bf8934d-075a-44a3-b665-ffce58b8f663 from 127.0.0.1
[19:02:28] [Core:Anonymous Error] : WebException
[19:02:28] [Core:Anonymous Error] : [0] (WebException) : The operation has timed out.
[19:02:28] [Core:Anonymous Error] :   at Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) 
  at Net.WebClient.GetWebResponse (Net.WebRequest request, IAsyncResult result) 
  at Net.WebClient.GetWebResponseTaskAsync (Net.WebRequest request) 
  at Net.WebClient.DownloadBitsAsync (Net.WebRequest request, IO.Stream writeStream, ComponentModel.AsyncOperation asyncOp, Action`3[T1,T2,T3] completionDelegate) 
  at AMPAPI.RemoteInstance.GetResponseDynamic (String Module, String Method, Object Parameters) 
  at AMPAPI.RemoteInstance+API_Core.Login (String username, String password, String token, Boolean rememberMe) 
  at GSMyAdmin.Authentication.RemoteAMPAuth.Authenticate (m.Http.IHttpRequest Request, String Username, String Password, String Token, Boolean TokenRequested, Collections.Generic.List`1[String]& Permissions, String& NewToken, GSMyAdmin.Authentication.UserInfoSummary& UserInfo) 
[19:02:28] [RemoteAMPAuth:Anonymous Activity] : Authentication attempt for user mc@8bf8934d-075a-44a3-b665-ffce58b8f663@8bf8934d-075a-44a3-b665-ffce58b8f663@8bf8934d-075a-44a3-b665-ffce58b8f663@8bf8934d-075a-44a3-b665-ffce58b8f663 from 127.0.0.1

I have no idea what to do here.

OS Name/Version: Ubuntu 16.04.6

Product Name/Version: AMP Instance Manager v1.9.1.2

Problem Description: Unable to log in with https

Steps to reproduce:

Step 1 Attempt to login
Step 2 Spins
Step 3 Timeout error, auth server unreachable

Actions taken to resolve so far: Ran command to setup certs, changed auth server on each instance config, synced all certs, enabled passthru auth

Mike posted this 05 January 2020

Well it's telling you what to do. Your auth server URL is wrong and needs updating to the current URL that ADS is reachable on. Just make sure you've also not been daft and not tried to make ADS itself use a login server since it is the login server.

Close