Unable to start TF2 Server

  • 69 Views
  • Last Post 1 weeks ago
roguelj posted this 4 weeks ago

OS Name/Version:

Ubuntu 18.04.3 LTS

Product Name/Version:

AMP Release "TITAN" v1.8.8.0, built 16/10/2019 17:26

Problem Description:

I am unable to start the TF2 server. I click 'Start', memory usage increases to 22Mb, then drops back to zero. I get the following line in /var/log/syslog:

amp kernel: [ 4003.027824] srcds_linux[27358]: segfault at 0 ip 00000000f67be621 sp 00000000ffc07730 error 6 in engine_srv.so[f6619000+2b2000]

Steps to reproduce:

Install AMP, create TF2 Server

Actions taken to resolve so far:

Not much! Hit Google, although it didn't turn up anything specific enough.

Notes:

During the install of AMP, the following line:

sudo apt-get install software-properties-common dirmngr apt-transport-https gnupg-curl

Resulted in the following error:

E: Unable to locate package gnupg-curl

Thanks in advance for any and all help.

Rog.

Order By: Standard | Newest | Votes
Mike posted this 4 weeks ago

When you installed AMP did you select the option to say you were going to be installing srcds servers?

roguelj posted this 4 weeks ago

That's odd, I don't even recall being asked!

I used the 'Advanced Install' instructions under Ubuntu.

I'll run through the install procedure again.

Cheers.

EDIT: I've just seen the following line:

sudo apt install lib32gcc1 lib32stdc++6 lib32tinfo5

And yes, I did install those dependencies during install.

Mike posted this 3 weeks ago

Can you do apt update && apt upgrade, reboot and try again?

Unfortunately its a segfault in the TF2 server itself which doesn't have much to do with AMP. But run the above first and see what happens.

roguelj posted this 3 weeks ago

Already tried that, no dice.

Checked for updates again, just in case, but there are no more available.

Gonna abandon this project now, but thank you for your help.

Mike posted this 3 weeks ago

I'd be interested to know if other SRCDS servers have the same issue on your system, maybe try L4D2 or CSGO?

roguelj posted this 1 weeks ago

L4D2 appears to work. I have not attempted to connect to it from a game but I can start the server and it remains running.

When I have more time to spare I'll tear this VM down and start again from scratch.

Cheers

Close