Using nginx as a reverse proxy: Login server unreachable.

  • 412 Views
  • Last Post 2 days ago
  • Topic Is Solved
ddt3 posted this 23 February 2020

I followed the instructions here: https://github.com/CubeCoders/AMP/wiki/Setting-up-secure-HTTP-with-AMP

Used the information described in "Manual nginx reverse proxy setup (advanced)"

For my local network I use my own CA to sign certificates. I have configured the generated public and private key in nginx.

In nginx https://games.familie-dokter.lan/ leads to http://localhost:8081/ this works perfectly for ADS01. I have created a new instance Minecraft in the browser and when I try to manage that instance I get this error message "Login server unreachable. Verify that the auth server URL in this instances config file is valid."

I have tried:

ampinstmgr reconfigure Minecraft01 +Core.Login.AuthServerURL https://games.familie-dokter.lan

and

ampinstmgr reconfigure Minecraft01 +Core.Login.AuthServerURL http://localhost:8081

But all to no avail...

Hope someone here can help me out

Order By: Standard | Newest | Votes
Mike posted this 23 February 2020

Have you updated the AuthServerURL setting inside ADS itself?

ddt3 posted this 23 February 2020

Thanks!

Greelan helped on Discord. I messed up Authservers etc. What i had to change to get it working again

  • No AuthServerURL and AuthServer set to false for ADS01
  • Using the web UI of ADS01: go to "new instance defaults" and set "Default auth server" to: http://localhost:8081 (=ADS01 address)

(@Mike: I know you know :-), just wanted to complete it if anyone else ever ends up here too)

  • Liked by
  • Chrys
Chrys posted this 2 days ago

Thanks! This was very helpful! :)

Close