2.1.1.4 - web interface does not update

  • 105 Views
  • Last Post 10 May 2021
  • Topic Is Solved
brianjd posted this 07 May 2021

After updating to 2.1.1.4, the web console does not update the status when starting or shutting down server. Once server is running it does not update to show server stats. I'm attaching a screenshot of the browser error (issue occurred in Firefox and mobile Safari)... picture upload seems to be failing. It's here: https://www.brianjd.com/files/amperror.png

enter image description here

Order By: Standard | Newest | Votes
Mike posted this 07 May 2021

Do a ampinstmgr --nocache upgradeall to re-update without the cache, then do a force-refresh in your browser (CTRL+F5) and it should all behave again.

brianjd posted this 08 May 2021

No change... the web page does not display any server stats, nor does it update. I can no longer get the Minecraft server to start.

brianjd posted this 08 May 2021

I was able to get the server running again... but still need to refresh to see any updates. I tried creating a new Minecraft Java server, and it had the exact same issue. No dynamic updates. I suspect it is due to the js error from my original screenshot. The AMP instance manager works, just the interface for managing the Minecraft servers is not updating.

Mike posted this 08 May 2021

Are you getting the same error(s) in the browsers F12 log?

brianjd posted this 09 May 2021

This is the browser Console from logging into the Minecraft instance: 

PluginHandler.js:70 Running init for MinecraftModule
PluginHandler.js:70 Running init for LocalFileBackupPlugin
PluginHandler.js:70 Running init for FileManagerPlugin
VM342:151 Uncaught (in promise) TypeError: Assignment to constant variable.
    at Object.updateSettingVisibility [as SettingChanged] (eval at scriptLoaded (PluginHandler.js:72), <anonymous>:151:50)
    at Object.NotifyPluginSettingChanged (PluginHandler.js:25)
    at Object.getSettingsCallback [as callback] (AMP.js:1274)
    at setupCalls (AMP.js:762)
    at async pluginsLoaded (AMP.js:560)
    at async Object.loginCallback (AMP.js:552)</anonymous>

Mike posted this 09 May 2021

Looks like you didn't actually get that update installed. Can you run that command again please and show me the output?

brianjd posted this 09 May 2021

I thought about what you are saying, and perhaps you created a new package or maybe the one I had was somehow corrupt. After looking at the output below, it was using the cache, even though I had set nocache. Might be something for you to look into. I deleted the cached package, ran the command again, and now it is working.

Thanks!! I copied the upgrade output that did not correctly observe the nocache setting. :)

    parents@home-server:~/AMP$ ./ampinstmgr --nocache upgradeall
[Info] AMP Instance Manager v1.6.10.0 built 09/09/2018 22:44
[Debug] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV
[Debug] Loading instances from /home/parents/.ampdata/instances.json...
[Debug] Loaded 3 instances.
[Info] Syncing certificate store using /etc/ssl/certs/ca-certificates.crt
[Debug] Current certificate store contains 132 items, system store contains 127
[Debug] Sync process completed.
[Info] Stopping Instance: 'ADSInstance'
[Info] Stopping instance ADSInstance...
[Debug] Running command line: "kill -SIGUSR1 1152" from "/home/parents/.ampdata/instances/ADSInstance"
[Info] Waiting for instance to stop...
[Debug] Running command line: "kill -SIGTERM 1152" from "/home/parents/.ampdata/instances/ADSInstance"
[Info] Instance ADSInstance has stopped.
[Info] Upgrading instance ADSInstance
[Debug] User: parents
[Debug] Home Dir: /home/parents
[Info] Using cached archive: /home/parents/.ampdata/instances/AMPCache-2114.zip
[Debug] Running command line: "unzip -qq -o "/home/parents/.ampdata/instances/AMPCache-2114.zip"" from "/home/parents/.ampdata/instances/ADSInstance"
[Info] Upgrade complete.
[Info] Stopping Instance: '2-Minecraft'
[Info] Stopping instance 2-Minecraft...
[Debug] Running command line: "kill -SIGUSR1 1213" from "/home/parents/.ampdata/instances/2-Minecraft"
[Info] Waiting for instance to stop...
[Debug] Running command line: "kill -SIGTERM 1213" from "/home/parents/.ampdata/instances/2-Minecraft"
[Debug] Running command line: "kill -SIGKILL 1213" from "/home/parents/.ampdata/instances/2-Minecraft"
[Info] Instance 2-Minecraft has stopped.
[Info] Upgrading instance 2-Minecraft
[Debug] User: parents
[Debug] Home Dir: /home/parents
[Info] Using cached archive: /home/parents/.ampdata/instances/AMPCache-2114.zip
[Debug] Running command line: "unzip -qq -o "/home/parents/.ampdata/instances/AMPCache-2114.zip"" from "/home/parents/.ampdata/instances/2-Minecraft"
[Info] Upgrade complete.
[Info] Upgrading instance Minecraft01
[Debug] User: parents
[Debug] Home Dir: /home/parents
[Info] Using cached archive: /home/parents/.ampdata/instances/AMPCache-2114.zip
[Debug] Running command line: "unzip -qq -o "/home/parents/.ampdata/instances/AMPCache-2114.zip"" from "/home/parents/.ampdata/instances/Minecraft01"
[Info] Upgrade complete.
[Debug] Running /usr/bin/tmux -f /dev/null new-session -s "AMP_ADSInstance" -d "cd '/home/parents/.ampdata/instances/ADSInstance'; /home/parents/.ampdata/instances/ADSInstance/AMP_Linux_x86_64 "
[Debug] Starting process /usr/bin/tmux
[Debug] Working Directory: /home/parents/.ampdata/instances/ADSInstance
[Debug] Arguments: -f /dev/null new-session -s "AMP_ADSInstance" -d "cd '/home/parents/.ampdata/instances/ADSInstance'; /home/parents/.ampdata/instances/ADSInstance/AMP_Linux_x86_64 "
[Debug] Started process with ID 274388
[Info] Waiting for AMP instance to start...
[Notice] AMP instance ADSInstance is now running.
[Debug] Running /usr/bin/tmux -f /dev/null new-session -s "AMP_2-Minecraft" -d "cd '/home/parents/.ampdata/instances/2-Minecraft'; /home/parents/.ampdata/instances/2-Minecraft/AMP_Linux_x86_64 "
[Debug] Starting process /usr/bin/tmux
[Debug] Working Directory: /home/parents/.ampdata/instances/2-Minecraft
[Debug] Arguments: -f /dev/null new-session -s "AMP_2-Minecraft" -d "cd '/home/parents/.ampdata/instances/2-Minecraft'; /home/parents/.ampdata/instances/2-Minecraft/AMP_Linux_x86_64 "
[Debug] Started process with ID 274409
[Info] Waiting for AMP instance to start...
[Notice] AMP instance 2-Minecraft is now running.

Mike posted this 10 May 2021

Your copy of ampinstmgr is badly outdated. Please make sure to get on the latest version. You probably need to update your apt keys.

As root:

apt-key adv --fetch-keys http://repo.cubecoders.com/archive.key

Then a normal apt update and upgrade.

Close