ADS Installation stuck on version 1.9.6.4 despite using latest download and windows showing 1.9.8.2

  • 121 Views
  • Last Post 06 April 2020
  • Topic Is Solved
Nickorain posted this 02 April 2020

OS Name/Version: Windows 10

Product Name/Version: AMP 1.9.8.4

Problem Description: "Cannot manage this instance This version of instance is not compatible with this ADS installation. ADS is version 1.9.6.4 but this instance is version 1.9.8.4" While updating from 1.9.6.4 to 1.9.8.4, i decided to uninstall, then install latest version, so that i could change which drive my files were being stored on (to an SSD). The above error message now shows up when i try to manage an instance thru browser.

Steps to reproduce:

Step 1. Install 1.9.8.4 Step 2. Go to "localhost:8080" login, and create a new Minecraft instance. Step 3. Click manage instance, error message appears.

Actions taken to resolve so far: Uninstalled and reinstalled AMP to make sure version is correct. Windows "programs" shows 1.9.8.2 if using the latest download file from "https://cubecoders.com/AMPInstall" Noticed browser shows "Application Version 1.9.6.4" under Support tab. Cleared cookies and cache in browser, no change. Attempted using different browser, no change.

Tried browsing forums here, couldn't find anything like this. It seems my browser thinks i'm still using 1.9.6.4, even though windows shows i'm using 1.9.8.2. I'm at a loss and my brain hurts. Any help would be appreciated, thanks.

Order By: Standard | Newest | Votes
Mike posted this 02 April 2020

Run 'ampinstmgr upgradeall' on the command prompt.

https://github.com/cubecoders/amp/wiki/How-to-update-AMP-to-the-latest-version

  • Liked by
  • Nickorain
Nickorain posted this 02 April 2020

upgradeall seemed to upgrade the instances, which were already 1.9.8.4, but didnt do anything to the "application" as shown in the browser page

Nickorain posted this 03 April 2020

using discord for support, i was recommended to start over due to what they saw in my instances

finally have the web browser showing 1.9.8.4. i believe the issue was me changing the IP binding setting when i created the first instance last night. leaving it at 0.0.0.0 now, took me to the first time setup page. if thats how its supposed to work then it was all my mistake sorry to be a noob

rabarber posted this 06 April 2020

I have the same problem but when i try "ampinstmgr upgradeall" it says:

[Info] AMP Instance Manager v1.9.8.4 built 01/04/2020 00:09
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Info] There are no instances to update.

and when i manually try to upgrade ADS: :~$ ampinstmgr upgrade ADS

[Info] AMP Instance Manager v1.9.8.4 built 01/04/2020 00:09
[Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Error] No such instance matching name: 'ADS'

Note: I've try to do this as my default user and sudo. For some reason i cannot login as 'amp' in my terminal. No password is accepted.

Im running a Minecraft server that i can manage but when i created a new instance it said:

Cannot manage this instance This version of instance is not compatible with this ADS installation. ADS is version 1.9.6.4 but this instance is version 1.9.8.4

EDIT: Im stupid, i needed to "ampinstmgr upgradeall" as the amp user.

Close