ADS related problem & question

  • Last Post 28 April 2021
  • Topic Is Solved
SirOndeth posted this 18 December 2018

Server configuration related to this thread :

3x (Root) Windows Server 2016 Standard with AMP Hawking Starman (

Hi Mike, until now I've used the AMP instance manager on my 3 Windows Server 2016 Standard root servers (A, B & C). Now I've decided to try out ADS as it works much smoother and everything is way better to manage (and it's the future of AMP :-P).

Installing and starting ADS on server A via the instance manager was no problem (installed as a service, auto-start on boot with correct server ip binding).

The first-start ADS configuration (configured as Hybrid, as server A should control itself and also server B & server C in the near future) also worked like a charm (except it did not restart automatically, but that's no problem).

After restarting server A I've decided to create a Minecraft instance for testing purposes through the ADS web interface. This instantly fails with the error

[14:35:18] [InstanceManager:Admin Error] : Failed to unpack AMP.
[14:35:18] [InstanceManager:Admin Error] : Access to the path 'C:\Users\server4main\AppData' is denied.

Exactly the same thing happens on any other instance installation, regardless of checking 'Create as standalone (Not managed by ADS)' - but not when using the local instance manager on server A.

The same thing (error) also occurs when trying above with server B / C .

I've checked the access rights for the related user(s) and AppData folder and AMP subfolders, but it's full access everywhere. Do you have any idea or advice to get ADS running properly?

By the way a small "feature" request: When failing such an instance installation in the ADS web interface, it would be cool when there's a notification like "Installation failed - Check the logs for further information" on the notification bar - currently the "Creating instance - Minecraft01" notification simply disappears without a notification that sth. failed

Order By: Standard | Newest | Votes
Mike posted this 18 December 2018

You need to relocate the datastore outside of the "Users" directory as per the installation instructions.

SirOndeth posted this 18 December 2018

Oh well... that was quickly solved ;-)

I guess I did not see that note on the AMP download page at that time I've installed AMP for the first time. I'll completely reinstall AMP then on the servers.

Thanks Mike!

Brille102 posted this 28 April 2021

I'm sorry to have to ask you again in another place, Mike.

I now have the following error and have already made sure that the Datastore folder is not in Users.

Failed to unpack AMP. UnauthorizedAccessException [0] (UnauthorizedAccessException) : Access to the path 'C:\AMPDatastore' is denied. at IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost) at IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost) at InstanceManagerPlugin.LocalInstanceManager.()

Mike posted this 28 April 2021

You probably touched the datastore outside of AMP, check what user owns that directory. The NETWORK SERVICE user requires full access to it.

Brille102 posted this 28 April 2021

Outstanding! Thank you very much for your excellent support

I have given the NETWORK SERVICE rights to the folder.

This solves the problem.