After Upgrade to 2.0.5 AMP thinks it's a controller instead of standalone

  • 126 Views
  • Last Post 24 August 2020
Gibbsman posted this 18 August 2020

OS Name/Version: Ubuntu 18.04.5

Product Name/Version: AMP 2.0.5

Problem Description:

After Upgrade to 2.0.5 AMP thinks it's a controller instead of standalone. Shows "No remote targets have yet been set up. This ADS installation has been setup as a controller, which means it cannot create instances by itself. You must create a Target ADS instance and register it with this controller before creating instances." instead of the instances as before

Actions taken to resolve so far: Tried to upgrade to 2.0.5 using -o, -p, -a. All seemed to upgrade fine, but when I tried to log in and restart my servers it says it's a controller and can't create instances. I don't know how to change it back to standalone.

Order By: Standard | Newest | Votes
Gibbsman posted this 18 August 2020

I forgot to mention that the ADSModule.kvp shows "ADS.Mode=Standalone"

ampinstmgr -t shows the instances running and the servers seem to be up, I just can't manage them from the ADS instance. If I connect directly to the port of the instance I can manage them that way.

Mike posted this 19 August 2020

Press CTRL+F5 in the browser

Gibbsman posted this 19 August 2020

I knew about that, as I’ve been using AMP for 5+ years, but it didn’t change anything. Multiple browsers, different PC’s, even my phone, all show the same thing.

Novae posted this 20 August 2020

I have the Same issue,

On my Controller, all Targets are gone.

And the Controller and Targets displays "This ADS installation has been setup as a controller" (whis is quite correct for the Controller but not for the targets ;)

CTRL+F5 shows that the cache was deleted, but dont change anything. The Target is still configured as Target in the ADSModule.kvp

Upgraded from 1.9.9.8 to 2.0.5

The Login to the Target with the Credentials from the Controller still works

Mike posted this 20 August 2020

Have you checked AMPs logs? Is it having any issues pulling data from its datastore?

Novae posted this 20 August 2020

I need to test some more, currently it is working partially and sometimes i get this screen back.

Then the Instances shown up and are gone after the next CTRL+F5 again

Pretty strange behavior.

I'll post the logs when I have more informations or an reproduceable scenario

Mike posted this 20 August 2020

Am I to assume both of you are using larger controller/target setups? If so can you try out the current nightly build please?

Gibbsman posted this 21 August 2020

I'm only using a single standalone server to host a few servers for my kids and their friends. Very low key. I've never used it in a controller/target setup. I've also been upgrading the same setup for the past 5'ish years, so it's totally possible that there are some weird artifacts from previous builds.

AMP Logs never really show much of interest for my regarding this issue. I can post them to pastebin or something if you'd like to see them. I can also try out the nightly build if you think it will help.

Novae posted this 21 August 2020

So, I Updated everything to Nightly. The Controller and 2/3 target are more stable.

The Windows Server ist still stuck with an error

Access denied: You do not have permission to use this method (ADSModule.GetApplicationEndpoints) at this time. This method requires the Session.Exists permission. (Origin: [myIP]:65467)

But the Windows server dont show up on the Controller anymore, not even in Red But the Windows Server have had aleready some issues before. So i think i'll jus reset this one and redeploy AMP to it

And for some reasons i cant reply to myself,

So Edit:

The Controler is stuck again. Error: https://pastebin.com/7QF32vi3

next edit: after waiting some time, the interface recovers and show the instances again, still strange

Mike posted this 21 August 2020

Hmm, nothing should be using that API call any more. If you're on Windows though you might need to do:

ampinstmgr --nocache upgradeall

Followed by a reboot.

Novae posted this 21 August 2020

Nope, still the same issue on the windows system.

Do you want to investigate this system some more? Else I'll just purge everything there and restart with AMP from scratch on this.

I'm not sure if the error on the Controller (see pastebin above) is related to the broken windows instance, or if this is an target issue, i cant even remove the Windows Instance from the Controler, because it dont shows up there anymore.

Anonther (offline) Debian instance is shown, also my two online target systems.

Edit: ok i have had the same error on the Controller at the same time the Windows Target was available again, so yes this both errors are related

Mike posted this 21 August 2020

Can you confirm the build date for the controller?

Novae posted this 21 August 2020

Yep, both Target (Windows) and Controller (Linux) have the Nighly Build from tonight.

AMP Release "Europa" v20200821.1, built 21/08/2020 03:00

Mike posted this 21 August 2020

Okay I've found the issue, a more in-depth update is required for some setups due to a change in how some of the data is serialized. Update shipping soon.

  • Liked by
  • Novae
Mike posted this 21 August 2020

Try the new 206 release.

Gibbsman posted this 21 August 2020

206 still shows the same error after me after upgrading all instances and flushing the cache. I've been needing an excuse to rebuild the entire thing anyway, so I'm just going to do that rather than continue troubleshooting.

Mike posted this 21 August 2020

Check with the new 206 release please

Novae posted this 24 August 2020

The Linux hosts are running fine. but i cant get the Windows Host back to the Controller, even after reinstalling the ADS on the Target.

Maybe there are some left overs from the old ADS target on the controller, because i never deleted the Server on the Controller but i cant see the windows target anymore on him...

For now i will switch back to Standalone on the Windows server, because i need to get the instances back up and running

edit: I restored an backup from the Windows VM and did an fresh upgrade from 1.9.9.8 to 2.0.6 everthing went fine, the error is gone and the ADS instance on the target is working fine again.

BUT the Controller instance is still broken, the Windows server dont come back and I dont have an backup vor this VM :-/

I'll test some more till tomorrow and then I'll try to switch back the (now working) target back to an mixed mode

Close