Allow custom docker-images

  • 98 Views
  • Last Post 03 December 2021
webcraft posted this 29 November 2021

Could you add the option to use our own podman-images? Yours contains a lot of overhead (e.g. many jre-versions and full distro). Also, it'd be great to add an option to the installer to use podman instead of docker. On modern systems, this is preferred by quite a few users these days I suppose. Additionally, docker-shim, which is required to make docker work on modern systems, is EOL soon: https://kubernetes.io/blog/2020/12/02/dockershim-faq/

Order By: Standard | Newest | Votes
Mike posted this 29 November 2021

You can already use custom images, and you can already use Podman as an alternative (Although AMP won't install+configure this for you just now)

Only the Minecraft instances use the version of the image with Java in. The base image only has the minimum required to support AMP (debian-10:slim is the base image). If you strip it down much further then AMP won't function - the base image is already pretty minimal.

https://github.com/CubeCoders/AMP/wiki/Using-custom-Docker-images-with-AMP-and-the-generic-module

webcraft posted this 29 November 2021

To be more specific, I mean an option in your webinterface to set this podman-image URL. And images creation not based on ampbase.

Mike posted this 29 November 2021

You must create your own configuration if you want to do anything custom. You must use images based on ampbase (or that as a minimum have the same ampstart.sh baked into them) so that AMP can interact with what's running inside it.

Using un-modified images isn't supported as a way of deploying applications in AMP and isn't going to be - the images need to be adapted to work with AMP and AMPs way of doing things. AMP is not a docker/podman frontend. A copy of AMP runs inside the container so it must meet the requirements of AMP itself.

If you wanted to do something completely custom or use unmodified images - you could use the Generic module to invoke docker/podman directly and bypass AMP for that part of the equation.

webcraft posted this 29 November 2021

I see but e.g. dpkg --add-architecture i386+"those 32-bit apps" for steam. Why would I want this, if I'm going to install Java for Minecraft only?
Is this one used for cubecoders/ampbase:latest : https://github.com/CubeCoders/dockerfiles/blob/master/Dockerfile
or which is the Dockerfile used for creating the cubecoders/ampbase:latest?

Mike posted this 30 November 2021

The ampbase docker file isn't publicly available at this time. I will publish the files somewhere at some point.

webcraft posted this 30 November 2021

If it was sooner than later (maybe at your git), it'd make this easier to create custom versions. Thanks

webcraft posted this 03 December 2021

Any chance to get the adopted Dockerfile to build our own base img?

Close