AMP Instance Manager crashing after upgrade to Ubuntu 17.10

  • 180 Views
  • Last Post 11 January 2018
  • Topic Is Solved
BigMichi1 posted this 02 January 2018

when i run ./ampinstmgr -q StarBound it crashes all the time after i upgraded to Ubuntu 17.10.

[Info] AMP Instance Manager v1.5.0.0 built 30/11/2017 15:31
[Debug] Release spec: Release - built by CUBECODERS/BuildBot on CCL-DEV
[Debug] Starting process /sbin/ldconfig
[Debug] Working Directory: /home/AMP/AMP
[Debug] Arguments: -p
[Debug] Started process with ID 21270
[Debug] Starting process /bin/uname
[Debug] Working Directory: /home/AMP/AMP
[Debug] Arguments: -m
[Debug] Started process with ID 21271
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.IO.MonoIO.Read (intptr,byte[],int,int,System.IO.MonoIOError&) [0x00000] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at System.IO.MonoIO.Read (System.Runtime.InteropServices.SafeHandle,byte[],int,int,System.IO.MonoIOError&) [0x00010] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at System.IO.FileStream.ReadData (System.Runtime.InteropServices.SafeHandle,byte[],int,int) [0x00002] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at System.IO.FileStream.ReadInternal (byte[],int,int) [0x00026] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at System.IO.FileStream.Read (byte[],int,int) [0x000a1] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at System.IO.StreamReader.ReadBuffer () [0x00028] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at System.IO.StreamReader.ReadLine () [0x00021] in <3574b7750bbd4f3481d1561b74d01b33>:0
  at ModuleShared.AMPProcess.GetLinuxCPUUsage () [0x000bc] in <457d9d83ea514f5ba1a9e03cf79826da>:0
  at ModuleShared.AMPProcess.get_CPUUsage () [0x00010] in <457d9d83ea514f5ba1a9e03cf79826da>:0
  at ModuleShared.AMPProcess.Start () [0x0049f] in <457d9d83ea514f5ba1a9e03cf79826da>:0
  at (wrapper remoting-invoke-with-check) ModuleShared.AMPProcess.Start () [0x00031] in <457d9d83ea514f5ba1a9e03cf79826da>:0
  at ModuleShared.AMPProcess.Start (System.Diagnostics.ProcessStartInfo,string) [0x00013] in <457d9d83ea514f5ba1a9e03cf79826da>:0
  at ModuleShared.Utilities.GetUtilityOutput (string,string,string,string,bool,int) [0x00063] in <457d9d83ea514f5ba1a9e03cf79826da>:0
  at InstanceManagerPlugin.LocalInstanceManager.GetArch () [0x00026] in <01ec2957cfbd45a4b874960b10db77a6>:0
  at InstanceManagerPlugin.LocalInstanceManager..ctor (ModuleShared.ILogger,ModuleShared.SupportedOS,ModuleShared.IRunningTasksManager,ModuleShared.IFeatureManager) [0x0007f] in <01ec2957cfbd45a4b874960b10db77a6>:0
  at InstanceManagerCLI.Core.Run () [0x00164] in <f9a5099131624717a3b86789d82ba632>:0
  at InstanceManagerCLI.Program.Main (string[]) [0x00005] in <f9a5099131624717a3b86789d82ba632>:0
  at (wrapper runtime-invoke) <module>.runtime_invoke_void_object (object,intptr,intptr,intptr) [0x0004e] in <f9a5099131624717a3b86789d82ba632>:0

[....]

Native stacktrace:

        ./ampinstmgr() [0x63ff78]
        ./ampinstmgr() [0x5ed010]
        /lib/x86_64-linux-gnu/libc.so.6(+0xa8416) [0x7f3ae0f19416]

Debug info from gdb:

Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
/tmp/mono-gdb-commands.1iAo1N:1: Error in sourced command file:
ptrace: Operation not permitted.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted

Order By: Standard | Newest | Votes
BigMichi1 posted this 11 January 2018

this one is working fine, no errors any more, thx

Mike posted this 11 January 2018

Sorry forum messed with my underscore, edited the post.

BigMichi1 posted this 11 January 2018

got a 404 when trying to download

Mike posted this 11 January 2018

Pastebin is generally the preferred way to link long outputs like that :)

Does this happen on the Nightly version of the IM? https://cubecoders.com/downloads/ampinstmgr_nightly.zip

  • Liked by
  • MidnightsFX
BigMichi1 posted this 11 January 2018

last part

Thread 3 (Thread 0x7f8ad8f0a700 (LWP 14089)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x1) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7f8ad970b700 (LWP 14088)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x0) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f8adacfb780 (LWP 14087)):
#0  0x00007f8ada8dba4a in waitpid () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000640009 in mono_handle_native_crash (signal=<optimized out="">, signal@entry=0x221d3c4 "SIGSEGV", ctx=ctx@entry=0x0, info=info@entry=0x0) at mini-exceptions.c:2567
#2  0x00000000005ed010 in altstack_handle_and_restore (ctx=0x7ffe5774c400, obj=0x0, stack_ovf=0) at exceptions-amd64.c:780
#3  0x00007f8ada591416 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#4  0x00007ffe5774c790 in ?? ()
#5  0x000000000044fba9 in mono_jit_runtime_invoke (method=0x7ffe5774ccf8, obj=0x0, params=0x229ec30, exc=<optimized out="">, error=0x7ffe5774cb30) at mini-runtime.c:2530
#6  0x00007f8ada5690d6 in vasprintf () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x00000000005836e9 in g_vasprintf (ret=0x7ffe5774ccb8, fmt=0x229ec30 "%s: unknown error (%d) \"%s\"", ap=0x7ffe5774ccf8) at gstr.c:62
#8  0x000000000057f55c in monoeg_g_logv (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR, format=0x229ec30 "%s: unknown error (%d) \"%s\"", args=0x7ffe5774ccf8) at goutput.c:112
#9  0x000000000057f631 in monoeg_g_log (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR, format=0x229ec30 "%s: unknown error (%d) \"%s\"") at goutput.c:125
#10 0x0000000000546e89 in mono_w32error_unix_to_win32 (error=3) at w32error-unix.c:66
#11 0x0000000000549625 in file_read (handle=0x8, buffer=0x7f8ad5ccd020, numbytes=1024, bytesread=0x7ffe5774ce44) at w32file-unix.c:1134
#12 0x0000000000550200 in ves_icall_System_IO_MonoIO_Read (handle=0x8, dest=<optimized out="">, dest_offset=<optimized out="">, count=1024, error=0x7ffe5774cf40) at w32file.c:880
#13 0x0000000041bca30a in ?? ()
#14 0x00007f8adab8ce00 in ?? ()
#15 0x00007f8adab8ce00 in ?? ()
#16 0x00007f8ad5ccd000 in ?? ()
#17 0x0000000000000000 in ?? ()

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

BigMichi1 posted this 11 January 2018

Thread 3 (Thread 0x7f8ad8f0a700 (LWP 14089)): #0 0x00007f8ada8d7072 in pthreadcondwait@@GLIBC2.3.2 () from /lib/x8664-linux-gnu/libpthread.so.0 #1 0x0000000000598358 in GCwaitmarker () at pthreadsupport.c:1903 #2 0x00000000005911ae in GChelpmarker (mymarkno=7) at mark.c:1116 #3 0x0000000000596e25 in GCmarkthread (id=0x1) at pthreadsupport.c:555 #4 0x00007f8ada8d07fc in startthread () from /lib/x8664-linux-gnu/libpthread.so.0 #5 0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7f8ad970b700 (LWP 14088)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x0) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f8adacfb780 (LWP 14087)):
#0  0x00007f8ada8dba4a in waitpid () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000640009 in mono_handle_native_crash (signal=<optimized out="">, signal@entry=0x221d3c4 "SIGSEGV", ctx=ctx@entry=0x0, info=info@entry=0x0) at mini-exceptions.c:2567
#2  0x00000000005ed010 in altstack_handle_and_restore (ctx=0x7ffe5774c400, obj=0x0, stack_ovf=0) at exceptions-amd64.c:780
#3  0x00007f8ada591416 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#4  0x00007ffe5774c790 in ?? ()
#5  0x000000000044fba9 in mono_jit_runtime_invoke (method=0x7ffe5774ccf8, obj=0x0, params=0x229ec30, exc=<optimized out="">, error=0x7ffe5774cb30) at mini-runtime.c:2530
#6  0x00007f8ada5690d6 in vasprintf () from /lib/x86_64-linux-gnu/libc.so.6
#7  0x00000000005836e9 in g_vasprintf (ret=0x7ffe5774ccb8, fmt=0x229ec30 "%s: unknown error (%d) \"%s\"", ap=0x7ffe5774ccf8) at gstr.c:62
#8  0x000000000057f55c in monoeg_g_logv (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR, format=0x229ec30 "%s: unknown error (%d) \"%s\"", args=0x7ffe5774ccf8) at goutput.c:112
#9  0x000000000057f631 in monoeg_g_log (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR, format=0x229ec30 "%s: unknown error (%d) \"%s\"") at goutput.c:125
#10 0x0000000000546e89 in mono_w32error_unix_to_win32 (error=3) at w32error-unix.c:66
#11 0x0000000000549625 in file_read (handle=0x8, buffer=0x7f8ad5ccd020, numbytes=1024, bytesread=0x7ffe5774ce44) at w32file-unix.c:1134
#12 0x0000000000550200 in ves_icall_System_IO_MonoIO_Read (handle=0x8, dest=<optimized out="">, dest_offset=<optimized out="">, count=1024, error=0x7ffe5774cf40) at w32file.c:880
#13 0x0000000041bca30a in ?? ()
#14 0x00007f8adab8ce00 in ?? ()
#15 0x00007f8adab8ce00 in ?? ()
#16 0x00007f8ad5ccd000 in ?? ()
#17 0x0000000000000000 in ?? ()

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

BigMichi1 posted this 11 January 2018

Debug info from gdb:

[New LWP 14088]
[New LWP 14089]
[New LWP 14090]
[New LWP 14091]
[New LWP 14092]
[New LWP 14093]
[New LWP 14094]
[New LWP 14095]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f8ada8dba4a in waitpid () from /lib/x86_64-linux-gnu/libpthread.so.0
  Id   Target Id         Frame 
* 1    Thread 0x7f8adacfb780 (LWP 14087) "ampinstmgr" 0x00007f8ada8dba4a in waitpid () from /lib/x86_64-linux-gnu/libpthread.so.0
  2    Thread 0x7f8ad970b700 (LWP 14088) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  3    Thread 0x7f8ad8f0a700 (LWP 14089) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  4    Thread 0x7f8ad8709700 (LWP 14090) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  5    Thread 0x7f8ad7f08700 (LWP 14091) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  6    Thread 0x7f8ad7707700 (LWP 14092) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  7    Thread 0x7f8ad6f06700 (LWP 14093) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  8    Thread 0x7f8ad6705700 (LWP 14094) "ampinstmgr" 0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
  9    Thread 0x7f8ad5f04700 (LWP 14095) "Finalizer" 0x00007f8ada8d9f96 in do_futex_wait.constprop () from /lib/x86_64-linux-gnu/libpthread.so.0

Thread 9 (Thread 0x7f8ad5f04700 (LWP 14095)):
#0  0x00007f8ada8d9f96 in do_futex_wait.constprop () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f8ada8da054 in __new_sem_wait_slow.constprop.0 () from /lib/x86_64-linux-gnu/libpthread.so.0
#2  0x00007f8ada8da144 in sem_wait@@GLIBC_2.2.5 () from /lib/x86_64-linux-gnu/libpthread.so.0
#3  0x00000000004ad7c9 in mono_os_sem_wait (flags=MONO_SEM_FLAGS_ALERTABLE, sem=0x2519c40 <finalizer_sem>) at ../../mono/utils/mono-os-semaphore.h:209
#4  mono_coop_sem_wait (sem=0x2519c40 <finalizer_sem>, flags=<optimized out="">) at ../../mono/utils/mono-coop-semaphore.h:40
#5  finalizer_thread (unused=unused@entry=0x0) at gc.c:907
#6  0x0000000000534ec8 in start_wrapper_internal (stack_ptr=0x7f8ad5f03d08, start_info=0x0) at threads.c:835
#7  start_wrapper (data=0x3ab0a10) at threads.c:887
#8  0x00000000005741c2 in inner_start_thread (data=0x3ab0b50) at mono-threads.c:1165
#9  0x0000000000597f76 in GC_start_routine (arg=0x7f8adac57fc0) at pthread_support.c:1508
#10 0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 8 (Thread 0x7f8ad6705700 (LWP 14094)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x6) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 7 (Thread 0x7f8ad6f06700 (LWP 14093)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x5) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 6 (Thread 0x7f8ad7707700 (LWP 14092)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x4) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 5 (Thread 0x7f8ad7f08700 (LWP 14091)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x3) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 4 (Thread 0x7f8ad8709700 (LWP 14090)):
#0  0x00007f8ada8d7072 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x0000000000598358 in GC_wait_marker () at pthread_support.c:1903
#2  0x00000000005911ae in GC_help_marker (my_mark_no=7) at mark.c:1116
#3  0x0000000000596e25 in GC_mark_thread (id=0x2) at pthread_support.c:555
#4  0x00007f8ada8d07fc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f8ada5fdb0f in clone () from /lib/x86_64-linux-gnu/libc.so.6

BigMichi1 posted this 03 January 2018

yes i rebooted many times

running screen and then execute ./ampinstmgr -q StarBound results in the same error

Mike posted this 02 January 2018

Okay, assuming you've rebooted already - try running it inside screen and see if the same still happens.

BigMichi1 posted this 02 January 2018

previous version was Ubuntu 17.04 and there everything was OK, there are no pending updates or upgrades at the moment

Mike posted this 02 January 2018

What version of Ubuntu were you on previously? Make sure there are no pending package updates and reboot.

Close