AMP instances crashing on launch, NullReferenceException

  • Last Post 21 September 2020
  • Topic Is Solved
CharAhNalaar posted this 21 September 2020

Two of my four instances are crashing on launch with this error. Latest AMP version, Ubuntu LTS 64bit system.

[04:45:30] [ErrorReporter Error]  : [Error] --- Begin Exception Data ---
[Error] OS: Linux (x86_64/None)
[Error] Module: MinecraftModule, Version: AMP
[Error] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV
[Error] Instance ID: 7938dd03-36ea-4746-a38d-e003d13085f3
[Error] NullReferenceException
[Error] [0] (NullReferenceException) : Object reference not set to an instance of an object
[Error]   at ModuleShared.SettingSectionStore.GetTaggedValues (Boolean OnlyReturnTrueBools, Boolean DropEnumsToStringsI$
  at MinecraftModule.ModuleMain+<>c.<saveminecraftserversettings>b__14_2 (Collections.Generic.KeyValuePair`2[TKey,TValu$
  at Linq.Enumerable+SelectManySingleSelectorIterator`2[TSource,TResult].MoveNext ()
  at MinecraftModule.ModuleMain.SaveMinecraftServerSettings (Boolean OverwriteAll)
  at (wrapper synchronized) MinecraftModule.ModuleMain.SaveMinecraftServerSettings(bool)
  at MinecraftModule.MinecraftApp.StartGameServer (Boolean autoRetry)
  at MinecraftModule.MinecraftApp.Start ()
  at GSMyAdmin.Core.StartUpdateApp (GSMyAdmin.Config config, ModuleShared.IApplicationWrapper App)
[Error] --- End Exception Data ---</saveminecraftserversettings>

Order By: Standard | Newest | Votes
Mike posted this 21 September 2020

Run ampinstmgr --nocache upgradeall

CharAhNalaar posted this 21 September 2020

That fixed it, thank you!