AMP Interface and API no longer showing number of active users on minecraft bedrock since update

  • 400 Views
  • Last Post 09 May 2021
  • Topic Is Solved
Cardy posted this 19 November 2020

OS Name/Version:

CentOS 8.2.2004

Product Name/Version:

AMP Release "Europa" v2.0.8.2, built 10/11/2020 17:57

Module Minecraft (Bedrock)

AMP Version │ 2.0.8.2

Release Stream │ Mainline

Problem Description:

Before the latest release when a user joined the server the manage instance page showed the correct number of users. This is no longer being updated and always shows 0.

I believe this is an issue related to the API as I have been writing a script to get the number of users from the API which was working fine.

I could query the instance of minecraft that was running using

"/API/Core/GetStatus" and the key "Metrics.Active Users.RawValue" would return the active number of users.

The API for the instance now always shows 0 for this metric.

I also query the endpoint "/API/Core/GetUserList" for the user list again previously this provided a list of the users xuid and Username. This now just appears to return an empty list.

Steps to reproduce:

Start bedrock instance Click on the instance and select manage Click on the status button so Active users is visible join the server Active Users remains at 0

Query the API for the endpoints above and even though I am successfully logged in I get back 0 for Active Users and the userlist is empty when querying appropriate endpoints.

Actions taken to resolve so far:

I have logged out on the frontend and cleared my cache. I have restarted the instances and even rebooted the server to get a clean startup after the upgrade. I have checked the logs but nothing is obvious to me as to why there is a problem.

Order By: Standard | Newest | Votes
Cardy posted this 09 May 2021

Thats great I will update to that asap.

Thanks

Lee

Mike posted this 07 May 2021

Version 2.1.1.4 has this fix in. :)

  • Liked by
  • Cardy
Cardy posted this 07 May 2021

Hi Mike,

I can confirm that switching to the Nightly build has made the Online user states and the listing of users in the API available once again.

Regards

Lee

Cardy posted this 06 May 2021

I assume that was the correct file then ?

Will give it a go tomorrow and let you know what happens.

Thanks

Lee

Mike posted this 06 May 2021

Okay, looks like they changed the message format slightly. Try the nightly build tomorrow :)

Cardy posted this 06 May 2021

The only other log I have found is the Dedicated_server.txt file

I have listed it below

Dedicated_Server.txt
[2021-05-06 10:06:39 INFO] Starting Server
[2021-05-06 10:06:39 INFO] Version 1.16.221.01
[2021-05-06 10:06:39 INFO] Session ID 0be23ecf-e23d-4801-a8f6-c6ef8f2298df
[2021-05-06 10:06:39 INFO] Level Name: Bedrock level
[2021-05-06 10:06:39 INFO] Game mode: 0 Survival
[2021-05-06 10:06:39 INFO] Difficulty: 1 EASY
[INFO] opening worlds/Bedrock level/db
[INFO] IPv4 supported, port: 23344
[INFO] IPv6 supported, port: 23345
[INFO] IPv4 supported, port: 54992
[INFO] IPv6 supported, port: 53006
[INFO] Server started.
[INFO] Player connected: Cardy165, xuid: 2523274766225732
[INFO] Player disconnected: Cardy165, xuid: 2523274766225732
[INFO] Server stop requested.
[INFO] Stopping server...

Cardy posted this 06 May 2021

Hi Mike,

I'm happy to get a log of this if you can let me know how I obtain it.

I can see the console log but not how to get the server to log to a file as you suggest.

Lee

elrooko posted this 04 May 2021

Where is this located and how do I enable this? Can't find this in the file structure

EDIT - There is no log file for Bedrock that I can tell.

Mike posted this 03 May 2021

Can you provide an excerpt from the log (the actual log file for Bedrock, not AMPs console) of players joining/leaving?

elrooko posted this 03 May 2021

Any update here? Is this resolved in 2.1.1.2?

ranstop posted this 09 April 2021

Can confirm this is still an issue today. This has also broke my webhooks which i relied on.

Do we have an ETA on this fix?

Thanks!

elrooko posted this 03 April 2021

Assuming this would affect webhooks as well from Bedrock? I'm not getting any events published out of bedrock so all my discord webhooks are not showing up...frustrating.

Is there an ETA?

Mike posted this 02 March 2021

Bedrock hasn't had any development time scheduled for it recently while we've been addressing other priorities. It will be looked at but it's just been less important for now.

Cardy posted this 02 March 2021

I still find that the number of users is not shown, they are also not available in the userlist via the API which I am guessing is a related issue.

It seems to work on Java Minecraft but not on bedrock.

Scott posted this 24 February 2021

Hi, it's been a couple months, and I just wanted to follow up if this was in the works for an upcoming release?

Thanks, Scott

Cardy posted this 15 December 2020

I was wondering if there was any update on this as the number of players and the names of players are still not available in the API.

Cardy posted this 07 December 2020

You've got to love it when the up stream vendor changes the format of the system without notice.

Fingers crossed its an easy fix to the new format.

Mike posted this 06 December 2020

It wasn't an API change, its an issue that prevents AMP from knowing that players have joined/left. Message syntax changed.

hedgehogspen posted this 06 December 2020

Yup, also on 2.0.8.6 and still have the same problem. As you say Cardy, a restart seemed to resolve the Notification issue.

Have also noticed that scheduled tasks are no longer working, but can see from another thread that Mike is looking at that, so I suspect the API thing is of lower priority.

Gotta love an API change...but hey, I'm sure if MS didn't keep changing stuff all the time Mike would only get bored :-)

Kylaris posted this 02 December 2020

I am having the same problem. It always shows 0/10 users.

Show More Posts
Close