AMP running in Docker- ADS01 Won't start in AMP web portal, but shows running in CLI

  • 109 Views
  • Last Post 14 October 2019
dpd26 posted this 08 October 2019

I've got AMP 1.8.7.0 running in Docker on a Ubuntu server. Everything appears to work fine apart from the portal shows ADS01 isn't running, but when i check in CLI it shows it as up. Pictures below to demonstrate.

Web Snip

CLI Snip

Any help appreciated. This is a new AMP instance with McMyAdmin2 license. Moved old minecraft data over to new instance

Thanks Darrell

Order By: Standard | Newest | Votes
Mike posted this 08 October 2019

Are you able to access it via ampinstmgr view ?

dpd26 posted this 08 October 2019

Yeah, that seems to work fine

Mike posted this 08 October 2019

Is ADS itself running inside docker?

dpd26 posted this 08 October 2019

Not 100% sure, it's my first time using docker. (Self teaching, yay!) I created this setup by doing a pull on cubecoders/amp and deploying that way. All of the instances ADS01 and McMyAdmin are in the same container if that helps

Thanks Darrell

Mike posted this 08 October 2019

Ah, the cubecoders/amp container is completely untested and probably doesn't work. You're supposed to install as per the normal guide and just turn on the docker flag in ADS once that is set up.

dpd26 posted this 08 October 2019

Ahhh no worries, I'll give that a go then! Could you pop us a link to the guide and I'll give it a bash?

Thanks also for replying at ludicrous times of the evening, can't mess with this stuff during the day job

Thanks Darrell

Mike posted this 08 October 2019

https://cubecoders.com/AMPInstall :)

dpd26 posted this 10 October 2019

Hi Mike,

Thanks for that, works a treat now as it's installed that way. One issue i'm having is when I add an SSL (One i purchased) to the ADS server, and change the Auth in the minecraft server to https, it doesn't work saying it can't find the auth server. Is there another config file or option i need to change for SSL?

Thanks Darrell

Mike posted this 14 October 2019

You need to change both the default auth server URL and the Login.AuthServerURL in AMPConfig.conf for any existing instances.

Close