Arma 3 Remove Default startup Arguments

  • 10 Views
  • Last Post 4 days ago
ryan1161 posted this 5 days ago

Here is the console log. Is there anyway to just have it load -par=startupparameters.txt -config=server.cfg because right now the server won't start it's just stuck and no arma logs or profiles are getting created.

Also RCON connection failed, console write unavailable. When will the rcon actually start working in the console of the web panel?

[20:30:15] [Arma3:mc Info]        : Checking for server at ./arma3/233780/arma3server [20:30:15] [Arma3:mc Info]        : File found OK [20:30:15] [Arma3:mc Debug]       : Writing first version of server config [20:30:15] [Core:mc Debug]        : Starting process ./arma3/233780/arma3server [20:30:15] [Core:mc Debug]        : Working Directory: ./arma3/233780 [20:30:15] [Core:mc Debug]        : Arguments: profiles=/home/mc/.ampdata/instances/TCArma3/arma3/233780/A3Master port=2302 ip=0.0.0.0 config=CONFIG_server.cfg cfg=basic.cfg world=empty -par=startupparameters.txt -config=server.cfg [20:30:15] [Core:mc Debug]        : Started process with ID 20512 [20:30:26] [Arma3:mc Warning]     : RCON connection failed, console write unavailable.

Order By: Standard | Newest | Votes
Mike posted this 4 days ago

I need to take another look at ARMA3 at some point soon. They recently changed how startup works entirely, so what used to work no longer does. Previously it required BattlEye to be loaded for example to have RCON support, and so far as I know that's no longer the case.

ryan1161 posted this 4 days ago

Yea they did change the startup cause I had some old ones on the server and couldn't get them to start but I do have a working start.sh till this module gets updated.

Close