Avorion with GenericModul

  • 83 Views
  • Last Post 3 weeks ago
Evilpla posted this 31 January 2020

Hi I managed to create a GenericModul config for Avorion and wanted to share it with the community. It is for Linux and Windows, but only tested for Linux.

Get the GenericModule.kvp here https://pastebin.com/Lyr9YxxX Enter your Steam ID to make you admin and you are good to go.

Order By: Standard | Newest | Votes
Evilpla posted this 31 January 2020

While using this Modul I found a possible bug, the log line that is configured with "Console.AppReadyRegex" is not appearing in the logfile.

Everything else is working fine with the new GenericModule, great work.

Mike posted this 31 January 2020

Awesome, could you submit this as a pull on github?

Mike posted this 31 January 2020

Also the OS field is wrong. It should be 3 for Windows + Linux.

Evilpla posted this 31 January 2020

Then you might check, your default kvp template, i took that OS field from there... should have done what the documentation says. I corrected this in the pastebin file.

I have no clue how github works, but feel free to put it there yourself.

shplamana posted this 3 weeks ago

Evilpla, did you manage to get the console to work correctly?

Currently amp logs the attempts to send stuff to the console, but it doesn't appear to work.

Evilpla posted this 3 weeks ago

I don't have problems with the console. Module is working fine for me.

shplamana posted this 3 weeks ago

Weird, I can't seem to send commands via the console in the instance.

It reads the console no problem, but I can't send anything to it.

The log looks like this:

Type 'help' for a list of commands.

[19:51:42] [System:admin Activity] : Sent to console: `help`

[19:51:45] [System:admin Activity] : Sent to console: `/help`

And the log is blank after that because it seems the console never receives the input.

Close