Backup Error in Minecraft Instance

  • 137 Views
  • Last Post 21 November 2020
  • Topic Is Solved
Shadown posted this 19 November 2020

OS Name/Version: Debian GNU/Linux (stretch) 9.13

Product Name/Version: AMP Release "Europa" v2.0.8.2, built 10/11/2020 17:57

Problem Description: Backups in the Minecraft Instance are not possible.

Error:

[20:24:28] [RunningTasksManager:Shadown Debug] : Task Creating Backup ( (173 MB)) failed: Unable to add /home/amp/.ampdata/instances/Minecraft/Minecraft/Welt2_nether/DIM-1/region/r.0.0.mca to archive: Win32 IO returned ERROR_NOT_SUPPORTED. Path: /home/amp/.ampdata/instances/Minecraft/Backups/DotNetZip-42vf7szx.tmp - aborting.

Log:

[20:24:21] [FileBackup:Shadown Activity] : Creating Backup: 
[20:24:21] [FileBackup:Shadown Debug] : Building file list...
[20:24:21] [FileBackup:Shadown Debug] : File list built: 370 files totaling 173MB
[20:24:21] [FileBackup:Shadown Debug] : Checking cycling requirements...
[20:24:21] [FileBackup:Shadown Debug] : Adding files to archive...
[20:24:22] [Server thread/INFO]: Saving the game (this may take a moment!)
[20:24:22] [FileBackup:Shadown Debug] : Saving archive...
[20:24:23] [Server thread/INFO]: Saved the game
[20:24:23] [Server thread/INFO]: Automatic saving is now disabled
[20:24:28] [Scheduler:Shadown Debug] : Running scheduled task Event.EmailSenderPlugin.SendMail for trigger A backup has failed.
[20:24:28] [EmailSender:Shadown Debug] : Sending email to #################...
[20:24:28] [EmailSender:Shadown Debug] : Done.
[20:24:28] [RunningTasksManager:Shadown Debug] : Task Creating Backup ( (173 MB)) failed: Unable to add /home/amp/.ampdata/instances/Minecraft/Minecraft/Welt2_nether/DIM-1/region/r.0.0.mca to archive: Win32 IO returned ERROR_NOT_SUPPORTED. Path: /home/amp/.ampdata/instances/Minecraft/Backups/DotNetZip-42vf7szx.tmp - aborting.
[20:24:34] [RunningTasksManager:Shadown Debug] : Task Creating Backup ( (173 MB)) ended: Acknowledged
  • The Backup Directory is not out of space
  • Auto Delete multiple old Backups is activated

Steps to reproduce: - Start a Backup

Actions taken to resolve so far: - Restart the instance and the server

Order By: Standard | Newest | Votes
Shadown posted this 21 November 2020

I deleted now the spigotbuild folder to reduce the size of the backup and deleted all the old backups. Now I have no Problems and it's deleting the old backups automatically. The asynchronous IO is still enabled and I am able to make Backups when the server is running. thanks for help

Mike posted this 21 November 2020

Other way around, it should be disabled if you want to be able to backup a server while it's still running. Can you take a backup when the server is stopped?

Shadown posted this 19 November 2020

it was disabled, and I enabled it now. But still no improvement

Mike posted this 19 November 2020

Is asynchronous IO enabled?

Close