Backup Plugin - Sticky Not Honored

  • 283 Views
  • Last Post 2 weeks ago
drakmir posted this 03 January 2018

OS Name/Version:

Ubuntu 16.04 BaseOS, Docker 17.11.0-ce (Running Ubuntu Xenial Base Image)

Product Name/Version:

AMP

Problem Description:

The backup plugin is sending a JSON to the back end with "Sticky" : "false" in all cases. This results in the backups not being marked as sticky.

Steps to reproduce:

Go to Backup Enter a Name Enter a Description Switch the Sticky to "True" Look at JSON transmitted to server, note that Sticky is false.

Actions taken to resolve so far: Changed Number of Backups to various settings from blank, 1 -> 999 Changed Max Backup size to various settings from blank, 1 - 1000000000

Also possibly related is that the notification popup ends up with a blank bar (no information) during many of the attempts. Especially if the maximum backup setting is set to 1.

Order By: Standard | Newest | Votes
Mike posted this 04 January 2018

We're looking into this.

Pigenavn posted this 3 weeks ago

Any news on this? Still does not work for me on Windows. :(

AMP Release "Europa" v2.0.2, built 17/07/2020 16:13

Mike posted this 2 weeks ago

Can you confirm that in the scheduler the task shows as "Take a sticky backup" ?

Pigenavn posted this 2 weeks ago

Yeah, tried both doing it with scheduler and manually. But still, in the JSON it says "Sticky":false.

Manual Sticky backup:
https://i.imgur.com/sz7nDcQ.png

JSON:

{"Id":"c078fba9-a4b3-4bbd-880d-50aeb9f0843d","Timestamp":"2020-07-28T20:22:13.6341176+02:00","ModuleName":"MinecraftModule","TakenBy":"admin","CreatedAutomatically":false,"Name":"StickyTest","Description":"This is a test","META":null,"TotalSizeBytes":1773475926,"Sticky":false}}

Diagnostics Data:
https://i.imgur.com/PinK9A7.png

Close