Backup setting tasks

  • 123 Views
  • Last Post 3 days ago
cloakndagger085 posted this 2 weeks ago

I seem to be having issues

Running AMP on CentOS Amp version TN/SR3 1.5.2.0 ASD Instance running a minecraft server

1) when doing a backup it seems to be backing up the whole sever is there a way to backup like MCMA2 would and just the world file?

2) When i assign the task of sending basically a server massage or message to everyone i click the green button and the task does not show up in the trigger, the only task i got to take so far was the reboot task

Order By: Standard | Newest | Votes
JohnE posted this 1 weeks ago

I'm running on Ubuntu 16.04 and I have the same issue on mine with 1.5.2, however I also had it with 1.5.0 and the nightly builds I tried.

While I can't answer your question 1 as I usually just grab the whole Minecraft folder to get settings and whitelist etc I found that Stop/Start server also work in tasks (though haven't found any others I can successfully scheduled after trying all of the send message to players or send console input to server). It'd be nice if those worked so I could warn people before backups. But since scheduled backup task won't work either I have to make do until that task works.

Warning: Use my workaround or scripts at your own risk, I'm not responsible for any issues that might arise.

To solve my own backup issues, I set the "Stop minecraft server" task for 4AM (seems to work).

I then made a cronjob for 4:02 AM:

AMP@localhost:/backup/minecraft$ crontab -l
# COMMENTS REDACTED TO SAVE POST SPACE
SHELL=/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

2 4 * * * /bin/bash /home/AMP/backup_minecraft.sh

To run a simple backup bash script:

#!/bin/bash
# Backup Minecraft folder from MCMA instance

stamp=$(date +"%Y-%m-%d-%H-%M-%S")
backup_name="/backup/minecraft/minecraft-backup-$stamp.tar.gz"
tar -cvzf $backup_name /home/AMP/.ampdata/instances/MCMA/Minecraft

And then at 4:05 I set another task in AMP to start the server (since my backups are small 3 minutes is currently plenty of time for my situation)

Since the server is only vanilla and small number of players none of this needs much time. Tonight will be the first test run but so far I've used different time settings to do a daytime test with success of the method overall.

harry7877 posted this 6 days ago

I upgraded to 1.5.2 and I'm having the same problem with trying to set a backup task.

The trigger shows up in the GUI The Task (Backup task in this case) does not show up in the GUI

Mike posted this 6 days ago

The scheduler issue is a known regression that's being investigated.

There is actually a mechanism to exclude files/directories but it's not too friendly to use right now. A future update will add a UI to this mechanism to make it easier.

Mike posted this 3 days ago

Latest nightly addresses this issue.

Close