Can't setup AMP Autostart on server boot

  • 167 Views
  • Last Post 20 December 2018
  • Topic Is Solved
Abuser posted this 15 December 2018

I'm on the latest nightly version of AMP and I created an instance for minecraft. I followed the install guide on the webpage and used the command provided to Start AMP on boot "(crontab -l ; echo "@reboot ampinstmgr -b")| crontab -". I even enabled my minecraft instance to start on boot via command and config file. When I reboot my machine (VPS running Ubuntu 16) AMP will not start up automatically. I want to be able to reboot my VPS when needed and have the AMP web panel automatically start without having to login via Putty and running it. Am I missing something here? I just installed AMP today for the first time.

My current Minecraft instance:

[Info] AMP Instance Manager v1.6.12.3 built 03/12/2018 21:30

Instance ID │ 85820ac9-87a0-430b-a613-93bf76e27df3 Module │ Minecraft

Instance Name │ Minecraft

Friendly Name │ AllTheMods

IP Binding │ 0.0.0.0

Port Number │ 8081

Running │ Yes

Daemon Installed │ No

Start on Boot │ Yes

AMP Version │ 1.6.12.4

Release Stream │ Nightly

Data Path │ /home/AMP/.ampdata/instances/Minecraft

Order By: Standard | Newest | Votes
Mike posted this 17 December 2018

Try editing the crontab to be the full path (/opt/cubecoders/amp/ampinstmgr) for the binary.

  • Liked by
  • Abuser
Abuser posted this 20 December 2018

Inputting the full path along with the "-b" parameter worked :D

Close