Can't upgrade AMP

  • 124 Views
  • Last Post 06 April 2020
  • Topic Is Solved
stefy97100 posted this 31 March 2020

This is what my console prompts when I run sudo apt upgrade:

(Reading database ... 68025 files and directories currently installed.) Preparing to unpack .../ampinstmgr1.9.8.4amd64.deb ... [Info] AMP Instance Manager v1.9.6.4 built 06/03/2020 14:06 [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV /var/lib/dpkg/info/ampinstmgr.prerm: 3: /var/lib/dpkg/info/ampinstmgr.prerm: systemctl: not found /var/lib/dpkg/info/ampinstmgr.prerm: 4: /var/lib/dpkg/info/ampinstmgr.prerm: systemctl: not found /var/lib/dpkg/info/ampinstmgr.prerm: 5: /var/lib/dpkg/info/ampinstmgr.prerm: systemctl: not found /var/lib/dpkg/info/ampinstmgr.prerm: 6: /var/lib/dpkg/info/ampinstmgr.prerm: systemctl: not found /var/lib/dpkg/info/ampinstmgr.prerm: 7: /var/lib/dpkg/info/ampinstmgr.prerm: systemctl: not found dpkg: warning: subprocess old pre-removal script returned error exit status 127 dpkg: trying script from the new package instead ... [Info] AMP Instance Manager v1.9.6.4 built 06/03/2020 14:06 [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV /var/lib/dpkg/tmp.ci/prerm: 3: /var/lib/dpkg/tmp.ci/prerm: systemctl: not found /var/lib/dpkg/tmp.ci/prerm: 4: /var/lib/dpkg/tmp.ci/prerm: systemctl: not found /var/lib/dpkg/tmp.ci/prerm: 5: /var/lib/dpkg/tmp.ci/prerm: systemctl: not found /var/lib/dpkg/tmp.ci/prerm: 6: /var/lib/dpkg/tmp.ci/prerm: systemctl: not found /var/lib/dpkg/tmp.ci/prerm: 7: /var/lib/dpkg/tmp.ci/prerm: systemctl: not found dpkg: error processing archive /var/cache/apt/archives/ampinstmgr1.9.8.4amd64.deb (--unpack): subprocess new pre-removal script returned error exit status 127 /var/lib/dpkg/info/ampinstmgr.postinst: 8: /var/lib/dpkg/info/ampinstmgr.postinst: systemctl: not found dpkg: error while cleaning up: subprocess installed post-installation script returned error exit status 127 Errors were encountered while processing: /var/cache/apt/archives/ampinstmgr1.9.8.4amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) root@evoburst:~#

Order By: Standard | Newest | Votes
stefy97100 posted this 31 March 2020

And at the end of this I update all the instances using "ampinstmgr upgradeall" and this is the result:

Writing "ampinstmgr -version" in the terminal I get

[Info] AMP Instance Manager v1.9.6.4 built 06/03/2020 14:06 [Info] Release spec: Release - built by CUBECODERS/buildbot on CCL-DEV

But on my instance in the bottom left there is

AMP Release "Lapetus"

v1.9.8.4, built 30/03/2020 14:39

Mike posted this 31 March 2020

What distro are you on?

stefy97100 posted this 31 March 2020

What distro are you on?

DISTRIB_ID=Ubuntu

DISTRIB_RELEASE=14.04

DISTRIB_CODENAME=trusty

DISTRIB_DESCRIPTION="Ubuntu 14.04.6 LTS"

NAME="Ubuntu"

VERSION="14.04.6 LTS, Trusty Tahr"

ID=ubuntu

ID_LIKE=debian

PRETTY_NAME="Ubuntu 14.04.6 LTS"

VERSION_ID="14.04"

Mike posted this 31 March 2020

Ubuntu 14.04 isn't supported. 16.04 is the absolute minimum, with 18.04+ being recommended.

stefy97100 posted this 06 April 2020

Thanks, I want to keep the 14.04 for now, I've noticed that when I try to install/remove something new with apt-get I always get

root@*:~# apt-get remove fail2ban

Reading package lists... Done

Building dependency tree

Reading state information... Done

The following packages were automatically installed and are no longer required:

lua-event lua-expat lua-filesystem lua-sec lua-socket lua5.1

python-pyinotify usbutils

Use 'apt-get autoremove' to remove them.

The following packages will be REMOVED:

fail2ban

0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.

3 not fully installed or removed.

E: Can't find a source to download version '1.9.6.4' of 'ampinstmgr:amd64'

And I can't install/remove packages.. Do you know how to remove pending upgrades?

Mike posted this 06 April 2020

I don't I'm afraid. I can't offer you any support for 14.04 (We're dropping support for 16.04 soon later this month too) - I'd suggest asking the Ubuntu community. Be aware that Ubuntu 14.04 is no longer getting security updates.

stefy97100 posted this 06 April 2020

Yeah I've read this.. Thanks anyway.. I'll update to 1.18 once we are no longer playing in the current server.

Close