Cannot start SRCDS Server inside AMP

  • 137 Views
  • Last Post 3 weeks ago
  • Topic Is Solved
Craigus posted this 02 March 2021

OS Name/Version: Windows Server 2019 x64

Product Name/Description: AMP Version 2.1.0.12

Problem Description: I'm trying to set up a CS:GO Server, I can start the instance in AMP but when I hit the server start button from within the instance the CPU activity will spike between 0% and 20% every couple of seconds. Watching the Task Manager on the host I can see that the srcds.exe process is starting and then disappearing in correlation with how the CPU activity is behaving. This will happen for a few minutes before the web interface gives a message that it's lost connection to the instance and the instance restarts. I can run and connect to a CS:GO server on this host using the valve setup instructions so I don't think it's port/network related. Thanks in advance!

Steps to Reproduce:

  • Create a new Instance for CS:GO
  • Update the Application from within the instance
  • Set parameters, i.e Server Name, Public Key, Maps etc
  • Start the server

Actions taken to resolve so far: I have created a new instance and get the same result, I have included Debug Level 0 Logs here: https://pastebin.com/ttaRM8nA

Order By: Standard | Newest | Votes
Craigus posted this 09 March 2021

Hi Everyone,

Just wondered if anyone has any suggestions on this one? I’m unsure where to go from here.

Cheers!

Mike posted this 09 March 2021

Do you have any instances other than your desired Csgo instance? Basically SRCDS doesn't always like running as a service on Windows.

Craigus posted this 11 March 2021

Hi Mike,

Thanks for your help with this! I thought I’d tried it without being set as a service but I clearly didn’t, the server is booting fine now.

Thanks again

Craig

GamingDuck posted this 4 weeks ago

Hi Craigus,

I am facing the same problem described by you when starting a csgo instance. Which setting did you change to make it work?

Thanks in Advance

GamingDuck posted this 3 weeks ago

BUMP

Hello, im really frustrated, I cant get my server to boot stable without it failing on me every few seconds... How/What do I have to change to not run srcds as a service???

Do you have any instances other than your desired Csgo instance? Basically SRCDS doesn't always like running as a service on Windows.

Edit: I know now that my srcds is NOT running as a service but its still rebooting aswell as that srcds.exe is working in another instance (Garrys Mod).

I took a look at the logs and found this but I couldnt find anything under that error/exit code:

[05:19:01] [System:AMPadmin Info] : Setting up RCON...
[05:19:01] [srcds:AMPadmin Warning] : The application stopped unexpectedly. Exit code -532265403
[05:19:02] [srcds:AMPadmin Warning] : The application stopped unexpectedly. Exit code -532265403
03/28/2021 - 05:19:04: Log file closed
[05:19:04] [srcds:AMPadmin Warning] : The application stopped unexpectedly. Exit code -532265403
[05:19:06] [srcds:AMPadmin Warning] : The application stopped unexpectedly. Exit code -532265403
03/28/2021 - 05:19:07: Log file closed
[05:19:07] [srcds:AMPadmin Warning] : The application stopped unexpectedly. Exit code -532265403

Close