Cant Connect With Load Balance Router

  • 467 Views
  • Last Post 11 September 2018
  • Topic Is Solved
Alper posted this 11 September 2018

I have two internet connection so im using Load Balance Router and i cant login web panel. But i can login with VPN or single ethernet connection. Can you fix this problem? My router is TPLink TL-R470T+ . There is error message: Unauthorized Access You do not have permission to use this method (WebMethods.GetUserList) at this time. This method requires the Session.LoggedIn permission.

Thrown by the 'Core' plugin while performing the 'GetUserList' method.

Advanced Details

at GSMyAdmin.WebServer.WebAttributes.InvokeMethod (String MethodName, Newtonsoft.Json.Linq.JObject Data, m.Http.IHttpRequest request, ModuleShared.IWebSession Session, ModuleShared.WebMethodsBase MethodsClass, String RawRequest) at GSMyAdmin.WebServer.APIService.InvokeAPI (m.Http.IHttpRequest request, ModuleShared.IWebSession Session, Newtonsoft.Json.Linq.JObject Data, String RequestModule, String RequestMethod, String RawRequest)

Order By: Standard | Newest | Votes
Mike posted this 11 September 2018

This occurs because AMP matches sessions up against their origin IP address to protect against certain types of attack. So if your IP address changes between requests it refuses to honour them.

Edit AMPConfig.conf and add this line:

Login.AllowInsecureMatching=true

Note that this does disable a key security feature, so use this at your own risk.

  • Liked by
  • Alper
Alper posted this 11 September 2018

Thanks for help. I will use VPN when connecting web panel. I dont want security problem.

Mike posted this 11 September 2018

If you use HTTPS then it's less of an issue, but if you just use HTTP it's more important.

Close