Certain recipes not working while running the server through AMP

  • Last Post 04 February 2018
  • Topic Is Solved
Lacyway posted this 03 February 2018

OS Name/Version: Windows Server 2016 - Version 1607 (Build 14393.2035)

Product Name/Version: AMP Instance Manager

Problem Description: When we run our FTB Revelation server through AMP certain recipes don't work. For example, we can't make planks out of logs. Running the server manually through "startserver.bat" that comes with the pack makes it work without any issues, but I'd like to use AMP if possible. I can only suspect that the server doesn't read the "scripts" folder properly but this is only an assumption.

Steps to reproduce: Download FTB Revelation 1.3.0 server files, install through "install.bat", move the files over and start the server.

Actions taken to resolve so far: Not running the server through AMP. Also tried passing the parameters from "startserver.bat" in AMP as a test but this had no effect on the issue.

Order By: Standard | Newest | Votes
Mike posted this 03 February 2018

The usual cause of this is having AMPs datastore in a users 'AppData' directory (especially if you installed as Administrator) - the solution is to move the datastore somewhere else (e.g. C:\AMP) and correct the permissions so that NETWORK SERVICE has full read/write access.

Lacyway posted this 04 February 2018

Hi Mike,

Thanks for the quick response. I re-installed AMP and set it up on C:\AMP and gave "NETWORK SERVICE" full access and it now works. Once again big thanks, I really appreciate it!