Certain recipes not working while running the server through AMP

  • Last Post 19 August 2018
  • Topic Is Solved
Lacyway posted this 03 February 2018

OS Name/Version: Windows Server 2016 - Version 1607 (Build 14393.2035)

Product Name/Version: AMP Instance Manager

Problem Description: When we run our FTB Revelation server through AMP certain recipes don't work. For example, we can't make planks out of logs. Running the server manually through "startserver.bat" that comes with the pack makes it work without any issues, but I'd like to use AMP if possible. I can only suspect that the server doesn't read the "scripts" folder properly but this is only an assumption.

Steps to reproduce: Download FTB Revelation 1.3.0 server files, install through "install.bat", move the files over and start the server.

Actions taken to resolve so far: Not running the server through AMP. Also tried passing the parameters from "startserver.bat" in AMP as a test but this had no effect on the issue.

Order By: Standard | Newest | Votes
Mike posted this 03 February 2018

The usual cause of this is having AMPs datastore in a users 'AppData' directory (especially if you installed as Administrator) - the solution is to move the datastore somewhere else (e.g. C:\AMP) and correct the permissions so that NETWORK SERVICE has full read/write access.

Lacyway posted this 04 February 2018

Hi Mike,

Thanks for the quick response. I re-installed AMP and set it up on C:\AMP and gave "NETWORK SERVICE" full access and it now works. Once again big thanks, I really appreciate it!

j1philli posted this 18 August 2018

Hey guys, I'm having this exact problem.

Can you guys give a guide on how to fix this problem. I've tried general guides on how to do this but now my instance doesn't start?

Thanks much appriciated

Mike posted this 18 August 2018

What happens when you try and start them? What errors/messsages/symptoms do you get?

j1philli posted this 18 August 2018

Typically the cmd would pop up when I click start and sit a little before going away and the check box popping up saying that it was running. Now it opens and closes so fast i don't even see the words and it doesn't start. I don't know where to find the logs for stiff like this. the only one I can find its for the the manager just starting

Mike posted this 19 August 2018

Did you create your instances as services?