Console doesn't work and restart/stop buttons don't show.

  • 165 Views
  • Last Post 21 May 2019
  • Topic Is Solved
jonjo posted this 19 May 2019

The buttons and console work the first time I start the ADS and SCRDS instance but if I restart or stop the server both stop working until I restart both instances again. At first it wouldn't work at all until I changed the IP from 192.168.0.10 to 127.0.0.1 and back again at which point it started working, however, at the same time it stopped me from being able to actually connect to the server, which worked fine previously. The port is forwarded and it's allowed in Windows firewall. I already spent over an hour with support staff in the discord to no avail. If this can't be resolved I would like to request a refund since the software is simply not fit for purpose while these issues exist.

Order By: Standard | Newest | Votes
Mike posted this 19 May 2019

Using 127.0.0.1 prevents anything other than localhost from connecting. Change it back to your systems IP and then use netstat to verify that it's actually is listening on the correct port.

As an aside staff aren't really around during weekends. If they don't have a green name and the cubecoders logo they're just another community member.

jonjo2 posted this 20 May 2019

as i said in the OP i switched it from 192 to 127 and then back again, it's already on 192. and yes its listening to the correct port [srcds.exe] UDP 192.168.0.10:27015 :

Mike posted this 20 May 2019

Is the selected map valid for the server type?

jonjo2 posted this 20 May 2019

yes. type is gmod map is gm_flatgrass. like i said, it worked before. i didnt change any of the settings other than switching to 127 and back to 192 so idk why it isnt working now. the issue isnt the map or anything, i get "Connection failed after 6 retries", though i do see the server in the server browser, i just cannot connect.

Mike posted this 20 May 2019

Are you connecting locally or remotely?

jonjo2 posted this 20 May 2019

locally

Mike posted this 20 May 2019

And what address are you connecting to in-game?

jonjo2 posted this 20 May 2019

192.168.0.10

Mike posted this 20 May 2019

Humour me and remove and then re-add the firewall rule allowing traffic to UDP/27015

jonjo2 posted this 21 May 2019

didn't make any difference.

Mike posted this 21 May 2019

Do you have a third party firewall installed perchance?

Basically if netstat shows that the port is listening but the game can't connect then that's not something AMP is involved with any more. So you've just got a plain ol' connectivity issue. But if there's no console then AMP is also having issues connecting (it uses the UDP logger built into srcds)

Can you post a screenshot of the output of netstat -an | find "LISTENING" and then if the UDP port shows up, the result of typing connect 192.168.0.10:27015 into gmods console? Also a screenshot of the srcds server console (which should show up when you hit start assuming its all local) would be helpful too. Imgur preferred.

jonjo2 posted this 21 May 2019

the console is working now, not sure why it was not before. https://i.imgur.com/AOqNMRE.png https://i.imgur.com/l5Rnjsq.png i tried typing that command in before and it gives the same result, connection failed after 6 retries

also here is netstat -a -p UDP since it doesnt show state for UDP connections https://i.imgur.com/tCd3FoG.png

jonjo2 posted this 21 May 2019

it's worth noting that if i run scrds by itself, without amp i can connect its only when i use amp it doesn't work. and i do have malwarebytes which includes network protection but i disabled it and it didnt make any difference

Mike posted this 21 May 2019

Then it's definitely a firewall issue. When Windows prompts to allow stuff through the firewall it uses the executable rather than the port.

Can you show me the firewall rules in the Windows firewall? You should have two incoming rules, one for TCP and another for UDP on port 27015.

jonjo2 posted this 21 May 2019

https://u.teknik.io/Q225r.mp4

Mike posted this 21 May 2019

Remove the Outbound rules. You only need inbound ones.

Also as a sanity check, do you have another machine that you can use to try and connect?

jonjo2 posted this 21 May 2019

the outbound rules aren't going to stop it working though is it? and no i do not have another machine to try and connect

Mike posted this 21 May 2019

Shouldn't do but I just want to remove anything that shouldn't be there.

Okay other sanity check, assuming you've port forwarded - what happens if you try to connect using your external IP?

Also it'd be helpful to put AMP into debug mode ( https://github.com/cubecoders/amp/wiki/Diagnosing-AMP-issues ) as this will show you the full set of arguments it's giving to the srcds server when it starts it up.

jonjo2 posted this 21 May 2019

its already in debug mode and connecting to external IP produces the same result

Mike posted this 21 May 2019

Okay, the other thing is in AMPConfig.conf for that instance - enable LogSensitiveProcArgs and set it to True.

Then start your srcds instance and check AMPs log, you'll see it gives the full set of arguments it's feeding to "srcds.exe" - Making sure to blank out any passwords, can you paste the entire log segment for me?

Also, is ADS running as a service?

Edit: I've just been dealing with another user on Discord who has a very similar issue. I'm suspecting that srcds make not like running as a service too much. If ADS is running as a service can you try temporarily renaming your instances directory so you've got a fresh set, and creating ADS as a non-service instance, and then creating your srcds instance again and see if that works?

Show More Posts
Close