Creation of new instance isn't working

  • 96 Views
  • Last Post 02 June 2020
  • Topic Is Solved
Domekologe posted this 28 May 2020

Hello all together,

I have problems to create a new instance.

  • The OS you're using and its version

LSB Version: :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch Distributor ID: CentOS Description: CentOS Linux release 7.8.2003 (Core) Release: 7.8.2003 Codename: Core

  • The name and version of the Cubecoders product you are using. Make sure to specify the actual version, and not just that it's the 'latest' version.

    AMP Release "Lapetus" v1.9.9.8, built 28/05/2020 10:37
    This issue also happens with the versions before

  • A description of the issue you are having.

When I create a new instance (4 instances are running) the instance will not possible to start. It doesn't matter which game I pick, this happens with all games.

I only see a message with "This task could not be completed: Starting Instance - Starting instancename

Also when I look into the folder, not all will be created. For Example: Logs Folder.

  • Steps to reproduce the issue (for bugs in particular)

    I don't know how there can be a reproduce.

  • What you have tried so far to resolve the issue and what happened.

Try an upgrade. Copy most files from another instance. Rename instances. Change ports. Disable Firewall.

  • A paste of any relevant output from the log file for a given AMP instance (where applicable).
[14:01:54] [Logger Info]          : Deleting 7 old log files...
[14:01:54] [Core Warning]         : Current time zone is set to CET - Servers should ideally be UTC to avoid time-zone related issues
[14:01:54] [Core Info]            : OS: Linux / x86_64
[14:01:54] [Core Info]            : CPU: Intel(R) Xeon(R) CPU E3-1231 v3 @ 3.40GHz (4C/8T)
[14:01:54] [Core Info]            : AMP Instance ID: d2d8f501-d7af-4749-9637-ca0b4edb7365
[14:01:54] [ModuleLoader Info]    : Loaded ADSModule version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : Loaded FileManagerPlugin version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : Loaded EmailSenderPlugin version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : Loaded WebRequestPlugin version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : Loaded LocalFileBackupPlugin version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : ADSModule requests dependency InstanceManagerPlugin...
[14:01:54] [ModuleLoader Info]    : Loaded InstanceManagerPlugin version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : ADSModule requests dependency SystemUserManagerPlugin...
[14:01:54] [ModuleLoader Info]    : Loaded SystemUserManagerPlugin version 1.0.0.0 by CubeCoders Limited
[14:01:54] [ModuleLoader Info]    : Loaded steamcmdplugin version 1.0.0.0 by CubeCoders Limited
[14:01:55] [WebServer Info]       : Websockets are enabled.
[14:01:55] [WebServer Info]       : Webserver started on 0.0.0.0:8080
[14:01:55] [Logger Warning]       : RouterTimer@10Hz with 2 jobs started
[14:01:55] [Core Info]            : Checking for AMP updates...
[14:01:55] [Core Info]            : AMP is up-to-date.
[14:02:07] [InstanceManager:Domekologe Info] : Using cached archive: /home/AMP/.ampdata/instances/AMPCache-1998.zip

There are no real info in Log and also the Log of new instance is completely missing:

[AMP@* ARK02]$ ll
total 71668
-rwx------  1 AMP AMP 73368100 May 28 11:40 AMP_Linux_x86_64
-rwx------  1 AMP AMP        7 May 28 14:02 AMPVersion
drwx------ 30 AMP AMP     4096 May 28 11:40 Plugins
drwx------  6 AMP AMP     4096 May 28 11:40 WebRoot
  • For AMP, which application module you're using. All Modules are not working!

Thanks for any help.

Best Regards, Domenick

EDIT: If somebody wants to see it:

Link

Order By: Standard | Newest | Votes
Mike posted this 02 June 2020

Try running the following:

ampinstmgr --nocache upgradeall
ampinstmgr fixperms
ampinstmgr repair
AMP_LOG_LEVEL=0 ampinstmgr startall

Domekologe posted this 02 June 2020

Hi,

thanks for you reply. I run all commands and now its working BUT

After I try to run "ampinstmgr repair", it doesn't recognized this command. I try to find out why and I see it.

All Instances are Up2Date BUT NOT the ampinstmgr itself. The Manager was run on 1.9.9.2 and I must make a manual upgrade of it (maybe its good to say, that the link "http://cubecoders.com/Downloads/ampinstmgr.zip" goes to an older version).

After that, I run again "repair" and the last one. The new instance was now able to run.

Thank you very much for your help.

Mike posted this 02 June 2020

If you're on CentOS you should be using the package manager to update AMP.

Close