Default java version not changing

  • 126 Views
  • Last Post 11 October 2021
  • Topic Is Solved
tomvos posted this 10 October 2021

I have installed AMP before I installed Java 17, which I want to use for MC. I am 100% sure Java 17 is the system default, however, it is not available in the java selection(only java 11).

Do I need to do something else that I may have forgotten?

Order By: Standard | Newest | Votes
Mike posted this 10 October 2021

Are you running the instance inside a Docker container?

tomvos posted this 10 October 2021

I'm not, since I don't know how docker works.

Mike posted this 10 October 2021

Are you on Windows or Linux?

tomvos posted this 11 October 2021

I'm using linux, ubuntu server 18.04 iirc.

Mike posted this 11 October 2021

Run the following as root:

bash <(wget -qO- getamp.sh) installJava

Then restart AMP. You should then get multiple Java versions to chose from in the selector.

tomvos posted this 11 October 2021

Found the problem.

I already tried that script a few times, but had only restarted the ads instance. Now I restared the ampinstmgr.service and it worked!

Thx!

Close