Dependencies TMUX SOCAT Centos 7

  • Last Post 07 February 2018
  • Topic Is Solved
ZephyrFire posted this 03 February 2018

Just bought a license and tried yo install on Centos 7 (Linux) So it says to yum install but I do this and it says No packages available. I searched through google and found some answeres but it says to compile it I need ncurses to compile it. I cant find any active repositories for ncurses so I cant use the program until I can install the dependencies. Your information is out of date. Please help me get AMP installed. Thank you.

Order By: Standard | Newest | Votes
Mike posted this 04 February 2018

Can you check the output of uname -a ? Also have you updated your repositories?

ZephyrFire posted this 05 February 2018

uname -a

Linux 3.10.0-693.17.1.el7.x8664 #1 SMP Thu Jan 25 20:13:58 UTC 2018 x8664 x8664 x8664 GNU/Linux

I am not sure hpw to to that. I did do yum clean all and then did yum -update -y

Mike posted this 05 February 2018

Just checked, CentOS 7 definitely has tmux and socat in its repositories as standard. Your installation is either damaged or your repositories are out of date.

ZephyrFire posted this 07 February 2018

Update ok the problem was on my end. The repo was corrupted and missing the base repo. Thanks forthe help